Bug 1244557 - initial-setup text install crashes on F-23
Summary: initial-setup text install crashes on F-23
Keywords:
Status: CLOSED DUPLICATE of bug 1244558
Alias: None
Product: Fedora
Classification: Fedora
Component: initial-setup
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F23AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-07-20 01:07 UTC by Peter Robinson
Modified: 2015-07-20 16:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-20 09:37:31 UTC


Attachments (Terms of Use)

Description Peter Robinson 2015-07-20 01:07:48 UTC
When running initial-setup on a Fedora text minimal install I get the following error:

$ initial-setup 
Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/initial_setup/__main__.py", line 5, in <module>
    import pykickstart
ImportError: No module named pykickstart
$

Even though both py kickstart modules are installed:
pykickstart.noarch                 2.11-1.fc23                           @System
python3-kickstart.noarch           2.11-1.fc23                           @System

Version is: initial-setup-0.3.33-2.fc23

Comment 1 Fedora Blocker Bugs Application 2015-07-20 01:11:06 UTC
Proposed as a Blocker for 23-alpha by Fedora user pbrobinson using the blocker tracking app because:

 Can't complete initial-setup to create a user and be able to login to the system

Comment 2 Adam Williamson 2015-07-20 03:23:41 UTC
I think minimal installs don't run initial-setup by design, though of course the package should have complete dependencies, I don't think this is actually a blocker. You can't complete an install without *either* creating a user account *or* setting a root password, and you can always log in to a console after doing that.

Comment 3 Peter Robinson 2015-07-20 09:02:33 UTC
(In reply to Adam Williamson from comment #2)
> I think minimal installs don't run initial-setup by design, though of course

It does run it, that is how the root password is set, TZ etc. That is exactly why I proposed it as a blocker because at the moment you get to a login prompt and you can't login (I believe that's because the root account is locked by default as it doesn't yet have a password, not 100% on that the locking though). IE the minimal image is basically unusable.

Comment 4 Vratislav Podzimek 2015-07-20 09:37:31 UTC
This is all about switching IS to Python 3.

*** This bug has been marked as a duplicate of bug 1244558 ***

Comment 5 Adam Williamson 2015-07-20 15:37:08 UTC
"It does run it, that is how the root password is set, TZ etc."

Nope, I'm pretty sure it doesn't. Do a 22 minimal install and see if you get it. initial-setup is not in @core.

"That is exactly why I proposed it as a blocker because at the moment you get to a login prompt and you can't login (I believe that's because the root account is locked by default as it doesn't yet have a password, not 100% on that the locking though). IE the minimal image is basically unusable."

Nope, this is not because of initial-setup. It's because of https://bugzilla.redhat.com/show_bug.cgi?id=1243168 . Do a re-label or boot with enforcing=0 and you'll be able to log in fine.

Comment 6 Peter Robinson 2015-07-20 15:50:47 UTC
> Nope, I'm pretty sure it doesn't. Do a 22 minimal install and see if you get
> it. initial-setup is not in @core.

I'm referring to the ARM minimal images [1] where we do, and always have had initial-setup, and unlike doing a minimal install where you set the password by either a prompt during install, or a kickstart, it's not what we do here or else every root password would be "fedora" or similar.

Test a 22 ARM minimal image and see for yourself.

[1] http://arm.fedoraproject.org/

Comment 7 Adam Williamson 2015-07-20 15:59:26 UTC
Oh, sure. But the bug has no arch specified, and the word ARM does not appear in the summary or the description...

Comment 8 Peter Robinson 2015-07-20 16:02:43 UTC
(In reply to Adam Williamson from comment #7)
> Oh, sure. But the bug has no arch specified, and the word ARM does not
> appear in the summary or the description...

it crashes on arches due to python3 (see the duped BZ)


Note You need to log in before you can comment on or make changes to this bug.