Bug 1248225

Summary: AttributeError: 'NoneType' object has no attribute 'path'
Product: [Fedora] Fedora Reporter: Boyd <bkelly>
Component: anacondaAssignee: Brian Lane <bcl>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: anaconda-maint-list, atnapes, dgb8296, g.kaviyarasu, goloch, GRNR19691, jonathan, joshuambenhase, Larry, lars, omkar.gongle, onedeathbyflame, robertolazo2005, sam, satellitgo, sjharms, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:3f101983f38f2431abead41a8d04ba42eca465f61aab87403dd8d89265aaec7a
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-06 18:18:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: anaconda-tb
none
File: anaconda.log
none
File: environ
none
File: journalctl
none
File: lsblk_output
none
File: nmcli_dev_list
none
File: os_info
none
File: program.log
none
File: storage.log
none
File: ifcfg.log none

Description Boyd 2015-07-29 22:47:53 UTC
Description of problem:
clicked on install to hard drive

Version-Release number of selected component:
anaconda-core-23.17-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/livepayload.py", line 78, in setup
    if not stat.S_ISBLK(os.stat(osimg.path)[stat.ST_MODE]):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/__init__.py", line 1277, in _runThread
    payload.setup(storage, instClass)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'NoneType' object has no attribute 'path'

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23_A-T2 ro rd.live.image quiet rhgb
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc3.git4.1.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23

Comment 1 Boyd 2015-07-29 22:48:06 UTC
Created attachment 1057436 [details]
File: anaconda-tb

Comment 2 Boyd 2015-07-29 22:48:08 UTC
Created attachment 1057437 [details]
File: anaconda.log

Comment 3 Boyd 2015-07-29 22:48:10 UTC
Created attachment 1057438 [details]
File: environ

Comment 4 Boyd 2015-07-29 22:48:17 UTC
Created attachment 1057439 [details]
File: journalctl

Comment 5 Boyd 2015-07-29 22:48:19 UTC
Created attachment 1057440 [details]
File: lsblk_output

Comment 6 Boyd 2015-07-29 22:48:20 UTC
Created attachment 1057441 [details]
File: nmcli_dev_list

Comment 7 Boyd 2015-07-29 22:48:22 UTC
Created attachment 1057442 [details]
File: os_info

Comment 8 Boyd 2015-07-29 22:48:24 UTC
Created attachment 1057443 [details]
File: program.log

Comment 9 Boyd 2015-07-29 22:48:30 UTC
Created attachment 1057444 [details]
File: storage.log

Comment 10 Boyd 2015-07-29 22:48:31 UTC
Created attachment 1057445 [details]
File: ifcfg.log

Comment 11 satellitgo 2015-08-06 21:59:05 UTC
Another user experienced a similar problem:

disks (dd) USB used to install via EFI boot to External USB HD with installed with f23 workstation

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-KDE-x86_64-23_A-1 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 23 (Twenty Three)
version:        23

Comment 12 satellitgo 2015-08-12 22:10:06 UTC
Another user experienced a similar problem:

try  to install from ext USB DVD to external USB HD with f23 Plasma install

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Cinnamon-x86_64-23_A rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 23 (Twenty Three)
version:        23

Comment 13 satellitgo 2015-08-13 00:49:47 UTC
(In reply to satellitgo from comment #12)
> Another user experienced a similar problem:
> 
> try  to install from ext USB DVD to external USB HD with f23 Plasma install
> 
> cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst
> --method=livecd:///dev/mapper/live-base
> cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img
> root=live:CDLABEL=Fedora-Live-Cinnamon-x86_64-23_A rootfstype=auto ro
> rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
> hashmarkername: anaconda
> kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
> other involved packages: python3-libs-3.4.3-5.fc23.x86_64
> package:        anaconda-core-23.17-1.fc23.x86_64
> packaging.log:  
> product:        Fedora
> reason:         AttributeError: 'NoneType' object has no attribute 'path'
> release:        Fedora release 23 (Twenty Three)
> version:        23
dd disks live dvd of Fedora-Live-Workstation-x86_64-23_Alpha-2.iso

Install worked after reformatted external USB HD with gnome-disks and restarted live usb to install Fedora-Live-Workstation-x86_64-23_Alpha-2.iso

intel NUC i3 bios boot
HD had a EFI GPT install

Comment 14 satellitgo 2015-08-13 14:35:57 UTC
Also got this error when tried to do EFI install of f23 KDE x86_64-23_Alpha-2 usb (gnome disks restore) to bios boot install with usb HD with Fedora-Live-Workstation-x86_64-23_Alpha-2.iso

sucessfully installed by using custom and deleting all partitions and adding :
gpt boot
/
/home
swap

auto creation of lvm failed first

Comment 15 Steve Harms 2015-08-14 17:30:16 UTC
Another user experienced a similar problem:

Launched installer

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23_A-2 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 23 (Twenty Three)
version:        23

Comment 16 David Shea 2015-08-17 19:00:13 UTC
*** Bug 1248673 has been marked as a duplicate of this bug. ***

Comment 17 Bahram Yasrebi Nezhad 2015-08-21 23:11:29 UTC
Another user experienced a similar problem:

I wanted to install fedora from live cd and this bug happens first thing in the choosing country!

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=/isolinux/initrd0.img root=UUID=8E98-CE33 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 rd.live.check BOOT_IMAGE=/isolinux/vmlinuz0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 18 Tim Lloyd 2015-09-06 23:48:26 UTC
Another user experienced a similar problem:

boot from usb
verify image - OK
elect to "install to HDD"
about to choose language and the error occurs

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23_A-2 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 23 (Twenty Three)
version:        23

Comment 19 roberto 2015-09-07 22:08:29 UTC
Another user experienced a similar problem:

1. I copy fedora 22 live iso to usb drive, using "universal usb installer".
2. boot de laptop, and at the boot line of grub, i erase "quick" parameter.
3. at the desktop, I use the fedora installer launcher from the icon.
4. at the beginning the assistant show the error message.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:LABEL=UUI NULL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 20 Tim Lloyd 2015-09-07 22:14:10 UTC
unplugged external USB drive during install. All good

Comment 21 dgb8296 2015-09-09 18:47:39 UTC
Another user experienced a similar problem:

Created bootable USB.
Started computer with bootable USB.
Fedora 23 Alpha opened.
Chose option "Install To Hard Drive"
After about one minute, the installation program opened.
A few seconds later, the bug occurred.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz0 root=live:LABEL=LIVE ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 23 (Twenty Three)
version:        23

Comment 22 LarryO 2015-09-13 13:51:57 UTC
Another user experienced a similar problem:

I tried to install KDE as a dual-boot configuration onto a disk that already has Windows   The language dialog came up and this error appeared before I had the chance to do anything.  I recreated the same problem 3 times.  The same disk has been used to install several other devices with no existing operating systems.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 23 Lars Kellogg-Stedman 2015-09-17 15:47:26 UTC
Another user experienced a similar problem:

Information to demonstrate the failure described in bz #1263832

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-23_A-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 23 (Twenty Three)
version:        23

Comment 24 Sam Kocher 2015-09-18 12:11:37 UTC
Another user experienced a similar problem:

Started install to hard disk and it crashes before I can perform the first screen choice:
anaconda 22.20.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/livepayload.py", line 78, in setup
    if not stat.S_ISBLK(os.stat(osimg.path)[stat.ST_MODE]):
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 1219, in _runThread
    payload.setup(storage, instClass)anaconda 22.20.13-1 exception report

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-LXDE-i686-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.i686
other involved packages: python-libs-2.7.9-6.fc22.i686
package:        anaconda-core-22.20.13-1.fc22.i686
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 25 Raja 2015-09-21 07:40:55 UTC
Another user experienced a similar problem:

1. I installed Fedora.
2.Formatted and installed windows
3.Then getting this bug while installing fedora

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz0 root=live:LABEL=LIVE ro rd.live.image quiet rhgb nomodeset
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 26 Sam Kocher 2015-09-24 22:00:47 UTC
Another user experienced a similar problem:

Booted from LiveUSB falsh with 16GB
modified /etc/fstab to include fake raid drives
/dev/sdb1             38G   32G  5.5G  86% /WINXP
/dev/sdb5             38G   15G   24G  39% /STORAGE
/dev/sdb3            392G  318G   74G  82% /WORK
/dev/sdc1             38G   32G  5.5G  86% /WINXP2
/dev/sdc3            392G  318G   74G  82% /WORK2
/dev/sdc5             38G   15G   24G  39% /STORAGE2
ASUS fake raid 2 500GB drives raid0 with three partitions
Install fails before I can select a target partition

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:UUID=92dabea7-9ce2-41f4-81b9-bb9b9de6ad9b rootfstype=ext4 rw rd.live.image rd.live.overlay=UUID=92dabea7-9ce2-41f4-81b9-bb9b9de6ad9b quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.i686
other involved packages: python-libs-2.7.9-6.fc22.i686
package:        anaconda-core-22.20.13-1.fc22.i686
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 27 joshuambenhase 2015-09-25 14:20:42 UTC
Another user experienced a similar problem:

Opened up 'install to hard drive' and boom.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:LABEL=UUI NULL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 28 joshuambenhase 2015-09-25 14:21:36 UTC
Another user experienced a similar problem:

opened up 'install to hard drive' and boom.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:LABEL=UUI NULL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 29 omkar.gongle 2015-09-26 19:52:55 UTC
Another user experienced a similar problem:

Steps I carried out -

1. Created live usb using liveusb-creator for Fedora22.
2. Booted using the live usb
3. On trying to install it on hard disk I faced this error

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:UUID=5280f541-8ec4-4852-9533-7993e89a7f45 rootfstype=ext4 ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 30 joshuambenhase 2015-09-26 19:56:29 UTC
What it looked like it may have been was the USB stick itself.  I used UUI to create a new Live Fedora and was able to install from that.  Never had any issues with that other stick before though.

Comment 31 Brian Lane 2015-09-29 00:19:55 UTC
This bug has kinda turned into a mess.

The point where this is failing just happens to be the point where things explode after a series of other problems.

The original bug appears to be a ntfsresize that failed. Several, using something called UUI are totally invalid, note the NULL in the kernel cmdline. Use dd, liveusb-creator or livecd-iso-to-disk to create media, not 3rd party tools that don't understand how Fedora works.

The others are impossible to tell without the anaconda-tb-* file.

Comment 32 Brian Lane 2015-09-29 00:29:28 UTC
If you are hitting this error and can give this patch a try it would be helpful:

https://github.com/rhinstaller/anaconda/pull/374

Comment 33 Lars Kellogg-Stedman 2015-09-29 17:53:24 UTC
> The others are impossible to tell without the anaconda-tb-* file.

Brian: Note that this failure can also be caused by the situation described in bz #1263832, which is trivially reproducible.

Comment 34 Brian Lane 2015-11-06 18:18:33 UTC
I'm going to close this, in F23 things should break sooner instead of hitting this catch-all point.