Bug 1248673 - AttributeError: 'NoneType' object has no attribute 'path'
AttributeError: 'NoneType' object has no attribute 'path'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:981f0fa38576d70f2281fb9b9b2...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 10:53 EDT by Gabriel Olochwoszcz
Modified: 2016-02-22 08:30 EST (History)
15 users (show)

See Also:
Fixed In Version: anaconda-23.19.6-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 02:27:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (394.42 KB, text/plain)
2015-07-30 10:53 EDT, Gabriel Olochwoszcz
no flags Details
File: anaconda.log (10.33 KB, text/plain)
2015-07-30 10:53 EDT, Gabriel Olochwoszcz
no flags Details
File: environ (613 bytes, text/plain)
2015-07-30 10:53 EDT, Gabriel Olochwoszcz
no flags Details
File: journalctl (321.02 KB, text/plain)
2015-07-30 10:53 EDT, Gabriel Olochwoszcz
no flags Details
File: lsblk_output (2.45 KB, text/plain)
2015-07-30 10:53 EDT, Gabriel Olochwoszcz
no flags Details
File: nmcli_dev_list (1.20 KB, text/plain)
2015-07-30 10:53 EDT, Gabriel Olochwoszcz
no flags Details
File: os_info (500 bytes, text/plain)
2015-07-30 10:53 EDT, Gabriel Olochwoszcz
no flags Details
File: program.log (16.91 KB, text/plain)
2015-07-30 10:53 EDT, Gabriel Olochwoszcz
no flags Details
File: storage.log (37.90 KB, text/plain)
2015-07-30 10:53 EDT, Gabriel Olochwoszcz
no flags Details
File: ifcfg.log (2.10 KB, text/plain)
2015-07-30 10:53 EDT, Gabriel Olochwoszcz
no flags Details

  None (edit)
Description Gabriel Olochwoszcz 2015-07-30 10:53:48 EDT
Version-Release number of selected component:
anaconda-core-22.20.13-1.fc22.x86_64

The following was filed automatically by anaconda:
anaconda 22.20.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/livepayload.py", line 78, in setup
    if not stat.S_ISBLK(os.stat(osimg.path)[stat.ST_MODE]):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 1219, in _runThread
    payload.setup(storage, instClass)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 244, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'NoneType' object has no attribute 'path'

Additional info:
cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:LABEL=UUI NULL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
product:        Fedora
release:        Fedora release 22 (Twenty Two)
type:           anaconda
version:        22

Potential duplicate: bug 1177273
Comment 1 Gabriel Olochwoszcz 2015-07-30 10:53:50 EDT
Created attachment 1057705 [details]
File: anaconda-tb
Comment 2 Gabriel Olochwoszcz 2015-07-30 10:53:51 EDT
Created attachment 1057706 [details]
File: anaconda.log
Comment 3 Gabriel Olochwoszcz 2015-07-30 10:53:52 EDT
Created attachment 1057707 [details]
File: environ
Comment 4 Gabriel Olochwoszcz 2015-07-30 10:53:54 EDT
Created attachment 1057708 [details]
File: journalctl
Comment 5 Gabriel Olochwoszcz 2015-07-30 10:53:55 EDT
Created attachment 1057709 [details]
File: lsblk_output
Comment 6 Gabriel Olochwoszcz 2015-07-30 10:53:55 EDT
Created attachment 1057710 [details]
File: nmcli_dev_list
Comment 7 Gabriel Olochwoszcz 2015-07-30 10:53:56 EDT
Created attachment 1057711 [details]
File: os_info
Comment 8 Gabriel Olochwoszcz 2015-07-30 10:53:57 EDT
Created attachment 1057712 [details]
File: program.log
Comment 9 Gabriel Olochwoszcz 2015-07-30 10:53:58 EDT
Created attachment 1057713 [details]
File: storage.log
Comment 10 Gabriel Olochwoszcz 2015-07-30 10:53:59 EDT
Created attachment 1057714 [details]
File: ifcfg.log
Comment 11 Kevin Kaminski 2015-08-01 15:03:54 EDT
Another user experienced a similar problem:

I created a Fedora Live USB drive, when I selected "Install to Hard Drive" I got this error at the start of the program. I have gotten a similar (If not the same) error when using a Live CD.
System Specs:
Intel Core i7 3770K
16GB Gskill Ram @2133
Asus P8 Z77-V Deluxe
Nvidia GTX 980
Samsung 840EVO 1TB w/30GB unallocated space intended for Fedora 22
Seasonic X-series 1050W

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-3 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22
Comment 12 V. Rotaev 2015-08-08 12:25:02 EDT
Another user experienced a similar problem:

Install fedora on hard disk with gpt

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-3 ro rd.live.image quiet rhgb nomodeset
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22
Comment 13 jaclark342 2015-08-09 20:03:07 EDT
Another user experienced a similar problem:

every time i go to install fedora from booting up on USB Live Distro I get error

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:LABEL=UUI NULL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22
Comment 14 mohammad 2015-08-09 23:09:47 EDT
Another user experienced a similar problem:

i have dell precision m4600
when i open install to Hard Drive this error show and install to Hard Drive close
i try it with root user too  problem exist

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22
Comment 15 juan 2015-08-15 20:15:21 EDT
Another user experienced a similar problem:

error

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=FEDORA-LIVE rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22
Comment 16 David Shea 2015-08-17 15:00:13 EDT

*** This bug has been marked as a duplicate of bug 1248225 ***
Comment 17 Brian Lane 2015-09-28 20:19:42 EDT
The original error here is:

Jul 30 10:48:45 localhost gnome-session[1380]: ERROR: pdc: identifying /dev/sda, magic_0: 0xe1e2e3e4/0xdc0620, magic_1: 0xd9dadbdc/0x0, total_disks: 0

File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 244, in run
threading.Thread.run(self, *args, **kwargs)

File "/usr/lib64/python2.7/threading.py", line 766, in run
self.__target(*self.__args, **self.__kwargs)

File "/usr/lib/python2.7/site-packages/blivet/osinstall.py", line 1116, in storageInitialize
storage.reset()

File "/usr/lib/python2.7/site-packages/blivet/blivet.py", line 277, in reset
self.devicetree.populate(cleanupOnly=cleanupOnly)

File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2127, in populate
self._populate()

File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2193, in _populate
self.addUdevDevice(dev)

File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1261, in addUdevDevice
self.handleUdevDeviceFormat(info, device)

File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1895, in handleUdevDeviceFormat
self.handleUdevDMRaidMemberFormat(info, device)

File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1674, in handleUdevDMRaidMemberFormat
rs_names = blockdev.dm.get_member_raid_sets(uuid, name, major, minor)

File "/usr/lib64/python2.7/site-packages/gi/overrides/BlockDev.py", line 384, in wrapped
raise transform[1](msg)

DMError: No RAIDs discovered

File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 244, in run
threading.Thread.run(self, *args, **kwargs)

File "/usr/lib64/python2.7/threading.py", line 766, in run
self.__target(*self.__args, **self.__kwargs)

File "/usr/lib64/python2.7/site-packages/pyanaconda/timezone.py", line 75, in time_initialize
threadMgr.wait(THREAD_STORAGE)

File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 115, in wait
self.raise_if_error(name)

File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 244, in run
threading.Thread.run(self, *args, **kwargs)

File "/usr/lib64/python2.7/threading.py", line 766, in run
self.__target(*self.__args, **self.__kwargs)

File "/usr/lib/python2.7/site-packages/blivet/osinstall.py", line 1116, in storageInitialize
storage.reset()

File "/usr/lib/python2.7/site-packages/blivet/blivet.py", line 277, in reset
self.devicetree.populate(cleanupOnly=cleanupOnly)

File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2127, in populate
self._populate()

File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2193, in _populate
self.addUdevDevice(dev)

File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1261, in addUdevDevice
self.handleUdevDeviceFormat(info, device)

File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1895, in handleUdevDeviceFormat
self.handleUdevDMRaidMemberFormat(info, device)

File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1674, in handleUdevDMRaidMemberFormat
rs_names = blockdev.dm.get_member_raid_sets(uuid, name, major, minor)

File "/usr/lib64/python2.7/site-packages/gi/overrides/BlockDev.py", line 384, in wrapped
raise transform[1](msg)

DMError: No RAIDs discovered


stat.S_ISBLK(os.stat(osimg.path)[stat.ST_MODE]) is ending up being a false-positive when something else fails.
Comment 18 Fedora Update System 2015-10-08 14:22:41 EDT
python-blivet-1.12.6-1.fc23 anaconda-23.19.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6f7d535c92
Comment 19 Fedora Update System 2015-10-09 09:55:01 EDT
anaconda-23.19.6-1.fc23, python-blivet-1.12.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update anaconda python-blivet'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6f7d535c92
Comment 20 Scott McGillivray 2015-10-10 12:43:05 EDT
Another user experienced a similar problem:

I've put a new Kingston SSD in my laptop which was running Windows 7 on the old hard drive.  I want to install Fedora on it.  I have used this Fedora disk on my desktop PC previously, so I know it's a good disk.  When I click "Install to Hard Drive", I get an error - 'NoneType' object has no attribute 'path'

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22
Comment 21 Scott McGillivray 2015-10-10 12:44:38 EDT
Another user experienced a similar problem:

I am trying to install Fedora on a new SSD on my laptop.  I keep getting this error.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22
Comment 22 Fedora Update System 2015-10-12 02:27:07 EDT
anaconda-23.19.6-1.fc23, python-blivet-1.12.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 23 spital 2015-11-25 04:56:44 EST
Another user experienced a similar problem:

Install to hard drive

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 live_dir=/multiboot/Fedora-Live-Workstation-x86_64-22-3/LiveOS initrd=initrd0.img root=live:LABEL=MULTIBOOT live_dir=/multiboot/Fedora-Live-Workstation-x86_64-22-3/LiveOS NULL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22
Comment 24 Muhammad Mubeen Mushtaq 2016-02-22 08:30:46 EST
Another user experienced a similar problem:

i was trying to install fedora 23 but after clining on install to hard drive i recieved an unknown error after that i am trying to install fedora 22 but m facing same problem after clicking on install to hard drive. i am using hp 420 g2 laptop with 1TB Hard drive and 8 GB of Ram

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-i686-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.i686
other involved packages: python-libs-2.7.9-6.fc22.i686
package:        anaconda-core-22.20.13-1.fc22.i686
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Note You need to log in before you can comment on or make changes to this bug.