Bug 1266396

Summary: After press "Auto-attach" in subscription-manager-gui the "Next" button should be gray until it find a available one.
Product: Red Hat Enterprise Linux 7 Reporter: xingge <gxing>
Component: subscription-managerAssignee: candlepin-bugs
Status: CLOSED DUPLICATE QA Contact: John Sefler <jsefler>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.2CC: alikins, ldai, liliu, qianzhan
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-09-25 11:41:16 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1121117    
Attachments:
Description Flags
the attachment none

Description xingge 2015-09-25 03:59:32 EDT
Description of problem:
After press "Auto-attach" in subscription-manager-gui the "Next" button should be gray until it find a available one.

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.15.9-11.el7.x86_64
subscription-manager-1.15.9-11.el7.x86_64
subscription-manager-initial-setup-addon-1.15.9-11.el7.x86_64
python-rhsm-1.15.4-5.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Prepare a system that registered and not have a subscription attached.
2.open subscription-manager-gui 
3.Press "Auto-attach" button on "My Installed Products" tab.
4.Press "Next" button when the subscription-manager is finding available subscriptions.


Actual results:
The Auto attach progress is interrupted and goes to a page that should not be showed. like the attachment

Expected results:
The "Next" button should be gray, untill it get a available subscription.

Additional info:
Comment 1 xingge 2015-09-25 04:01 EDT
Created attachment 1076927 [details]
the attachment
Comment 2 Adrian Likins 2015-09-25 11:41:16 EDT

*** This bug has been marked as a duplicate of bug 1261006 ***