Bug 1269707

Summary: RFE: fedpkg-like commands - clone, prep, local, srpm, sources
Product: [Community] Copr Reporter: Jens Petersen <petersen>
Component: cliAssignee: Miroslav Suchý <msuchy>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: clime, hhorak, praiskup
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-02 11:43:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jens Petersen 2015-10-08 02:52:37 UTC
Description of problem:
Now that Copr has (readonly) distgit support (thanks so much!)
it would be cool if copr-cli could support fedpkg-like commands
such as 'clone', 'prep', 'local', 'srpm', etc.
Allowing 'build' to also build from current git working dir
would also be nice: maybe it could get sort out git pull
after successful build?

Version-Release number of selected component (if applicable):
copr-cli-1.44-1.fc22

Comment 1 Pavel Raiskup 2017-01-17 14:41:55 UTC
Jens, you can (with a bit of work) rpkg.  See the "see also" bug with PoC,
that's read-only of course.
https://bugzilla.redhat.com/show_bug.cgi?id=1410403

Comment 2 Jens Petersen 2017-07-06 02:58:34 UTC
Thanks I installed fedpkg-copr

Comment 3 clime 2017-11-02 11:43:59 UTC
Hey Jens!

We now have `rpkg` command-line utility exactly for this. It is based on python-rpkg library and does exactly what you have asked for. Upstream is placed here: https://pagure.io/rpkg-client (name of the repository is rpkg-client because there already exists rpkg repo, which is the library).

Thank you for this suggestion!