Bug 1282691

Summary: Make the ovirt lago tests run for master code
Product: [Community] ovirt-system-tests Reporter: Eyal Edri <eedri>
Component: CoreAssignee: Yaniv Kaul <ykaul>
Status: CLOSED CURRENTRELEASE QA Contact: Pavel Stehlik <pstehlik>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 0.4CC: bugs, eedri, tlitovsk, ykaul
Target Milestone: ---Keywords: Automation
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ci
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1278491 Environment:
Last Closed: 2016-06-27 03:22:40 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1279411    

Description Eyal Edri 2015-11-17 01:38:22 EST
Description of problem:

Make lago be able to run on oVirt master code (4.0) via jenkins job and local developer mode.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-05 10:31:47 EST ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-05 10:31:47 EST ---

This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.

--- Additional comment from Eyal Edri on 2015-11-05 10:42:51 EST ---

for this to work we need to create a stable repo to hold latest stable (currently 0.3) and also latest repo.

also related to: Bug 1277650 - Automate the lago rpm distribution
https://bugzilla.redhat.com/show_bug.cgi?id=1277650

tolik,
would you be able to take ownership on this once the blocker bug will be done?

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-05 10:42:54 EST ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-05 10:42:54 EST ---

This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.

--- Additional comment from Eyal Edri on 2015-11-05 10:48:04 EST ---

for this to work we need to create a stable repo to hold latest stable (currently 0.3) and also latest repo.

also related to: Bug 1277650 - Automate the lago rpm distribution
https://bugzilla.redhat.com/show_bug.cgi?id=1277650

This bug means to add 3.6 jenkins job, another bug will be opened to verify the readme is updated for 3.6

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-05 10:48:07 EST ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-05 10:48:07 EST ---

This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-05 10:49:30 EST ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-12 05:19:05 EST ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 1 Eyal Edri 2016-04-10 09:49:43 EDT
Changing assignee, please feel free to re-assign to relevant teams.
Comment 2 Eyal Edri 2016-06-19 08:35:17 EDT
working both on 4.0 and master:

master job: http://jenkins.ovirt.org/view/oVirt%20system%20tests/job/ovirt_master_system-tests/

Not sure if we want to keep this bug open until we move master to use V4 of the API.

Yaniv, is it stable yet so we can move?
Comment 3 Eyal Edri 2016-06-26 03:49:04 EDT
It is stable for the past weeks. 
We'll soon move it to use API v4, but there will be a different bug open on it.