Bug 1297447 (CVE-2016-1569)

Summary: CVE-2016-1569 firebird: authenticated remote crash by gbak invocation
Product: [Other] Security Response Reporter: Andrej Nemec <anemec>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: makowski.fedora
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-02 11:55:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1297450, 1297451    
Bug Blocks:    

Description Andrej Nemec 2016-01-11 14:40:12 UTC
Firebird 2.5.5 can be crashed remotely by authenticated clients by invoking 
gbak via the service manager using invalid command line switch.

This is harmless for the -classic flavour where the server process serves only 
that particular connection, but is at least a DoS for -super and -superclassic 
where the crashed process serves multiple connections.

Upstream issue:

http://tracker.firebirdsql.org/browse/CORE-5068

CVE request:

http://seclists.org/oss-sec/2016/q1/57

Comment 1 Andrej Nemec 2016-01-11 14:45:55 UTC
Created firebird tracking bugs for this issue:

Affects: fedora-all [bug 1297450]
Affects: epel-all [bug 1297451]

Comment 2 Fedora Update System 2016-02-11 13:21:29 UTC
firebird-2.5.5.26952.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 3 Fedora Update System 2016-02-25 06:30:20 UTC
firebird-2.5.5.26952.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2016-02-26 06:57:28 UTC
firebird-2.5.5.26952.0-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Philippe Makowski 2016-11-02 11:55:47 UTC
Patch from upstream applied