Bug 1310892

Summary: gnome-terminal hyperlink detection broken in xml
Product: Red Hat Enterprise Linux 6 Reporter: Christopher Tubbs <ctubbsii>
Component: gnome-terminalAssignee: Debarshi Ray <debarshir>
Status: CLOSED WONTFIX QA Contact: Desktop QE <desktop-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.9CC: egmont
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1310894 (view as bug list) Environment:
Last Closed: 2017-12-06 07:34:17 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1310894    

Description Christopher Tubbs 2016-02-22 17:41:59 EST
Description of problem:
When I Ctrl-click a link in gnome-terminal, it opens in the default browser. However, if the link is in an XML tag, the first character of the closing tag "<" is always included in the hyperlink when it is highlighted (underlined) and clicked.

Version-Release number of selected component (if applicable):
gnome-terminal-2.31.3-11.el6_6.x86_64 (affects every version of RHEL/CentOS/Fedora I've tried, but this is what's on my current system)

How reproducible:
100%

Steps to Reproduce:
1. Paste: "<url>https://bugzilla.redhat.com</url>" into gnome-terminal
2. Ctrl+click on the link

Actual results:
Browser tries to open "https://bugzilla.redhat.com<"

Expected results:
Browser should open "https://bugzilla.redhat.com"

Additional info:

This bug has been irritating me for many RHEL and Fedora releases.

While angle brackets can be used to delimit a URI (http://www.ietf.org/rfc/rfc3986.txt), it's generally unsafe to use without urlencoding (http://www.blooberry.com/indexdot/html/topics/urlencoding.htm), so it should never be seen as part of the URL itself.

Even if it were seen in a valid URL, I think the use-case of Ctrl+clicking from XML is a much more reasonable use case to support, because it is much more likely users will want to click on URLs inside XML than to click on a URL that actually happens to have a less-than sign in it.

Further, even if it were expected behavior to include the less-than character as part of the URL, the very next characters ('/url>' in my example) would also be valid, but are clearly not included in the URL... so clearly, this is a bug.
Comment 2 Egmont Koblinger 2016-02-22 19:33:34 EST
There are many more problems with URL detection. Upstream fix is at https://bugzilla.gnome.org/show_bug.cgi?id=756038. No easy way and no simple patch to backport to old branches exists.
Comment 3 Egmont Koblinger 2016-03-04 15:06:19 EST
I've backported the fix to the 3-18 branch (and hopefully applies cleanly to older ones as well):
https://git.gnome.org/browse/gnome-terminal/commit/?h=gnome-3-18&id=3bd692f
Comment 4 Jan Kurik 2017-12-06 07:34:17 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/