Bug 1324701

Summary: Create Repo failed with : [E] RuntimeError: There was an issue with the backend service pulp: No pulp workers running.
Product: Red Hat Satellite 6 Reporter: Tazim Kolhar <tkolhar>
Component: RepositoriesAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.2.0CC: cwelton
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-04-07 13:50:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
foreman-debug attached none

Description Tazim Kolhar 2016-04-07 03:18:44 UTC
Created attachment 1144534 [details]
foreman-debug attached

Description of problem:
Create Repo failed with : [E] RuntimeError: There was an issue with the backend service pulp: No pulp workers running.

Version-Release number of selected component (if applicable):
# rpm -qa foreman
foreman-1.11.0.9-1.el7sat.noarc

How reproducible:
everytime

Steps to Reproduce:
1.Create a product
2.Try to add repo
3.While you are adding repo, skip this and Click on the product
4.Select the product
5.Click Bulk Actions -> Remove product
6.| /opt/theforeman/tfm/root/usr/share/gems/gems/logging-1.8.2/lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context'
2016-04-06 23:00:43 [foreman-tasks/action] [E] There was an issue with the backend service pulp: No pulp workers running. (RuntimeError)
 




Actual results:
the repo create failed

Expected results:
the repo create works

Additional info:
As, workaround I executed katello-service restart and was able to create a prod
add repo and sync it

Comment 1 Tazim Kolhar 2016-04-07 13:50:12 UTC

*** This bug has been marked as a duplicate of bug 1321644 ***