Bug 1324701 - Create Repo failed with : [E] RuntimeError: There was an issue with the backend service pulp: No pulp workers running.
Summary: Create Repo failed with : [E] RuntimeError: There was an issue with the backe...
Keywords:
Status: CLOSED DUPLICATE of bug 1321644
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-07 03:18 UTC by Tazim Kolhar
Modified: 2016-04-26 00:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-07 13:50:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman-debug attached (313.25 KB, application/x-xz)
2016-04-07 03:18 UTC, Tazim Kolhar
no flags Details

Description Tazim Kolhar 2016-04-07 03:18:44 UTC
Created attachment 1144534 [details]
foreman-debug attached

Description of problem:
Create Repo failed with : [E] RuntimeError: There was an issue with the backend service pulp: No pulp workers running.

Version-Release number of selected component (if applicable):
# rpm -qa foreman
foreman-1.11.0.9-1.el7sat.noarc

How reproducible:
everytime

Steps to Reproduce:
1.Create a product
2.Try to add repo
3.While you are adding repo, skip this and Click on the product
4.Select the product
5.Click Bulk Actions -> Remove product
6.| /opt/theforeman/tfm/root/usr/share/gems/gems/logging-1.8.2/lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context'
2016-04-06 23:00:43 [foreman-tasks/action] [E] There was an issue with the backend service pulp: No pulp workers running. (RuntimeError)
 




Actual results:
the repo create failed

Expected results:
the repo create works

Additional info:
As, workaround I executed katello-service restart and was able to create a prod
add repo and sync it

Comment 1 Tazim Kolhar 2016-04-07 13:50:12 UTC

*** This bug has been marked as a duplicate of bug 1321644 ***


Note You need to log in before you can comment on or make changes to this bug.