Bug 1330055

Summary: Replace UDisks2 by Storaged
Product: [Fedora] Fedora Reporter: Jan Kurik <jkurik>
Component: Changes TrackingAssignee: Tomas Smetana <tsmetana>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: awilliam, tsmetana
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ChangeAcceptedF25, SystemWideChange
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-22 13:59:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1347415    
Bug Blocks:    

Description Jan Kurik 2016-04-25 10:59:45 UTC
This is a tracking bug for Change: Replace UDisks2 by Storaged
For more details, see: https://fedoraproject.org//wiki/Changes/Replace_UDisks2_by_Storaged

Storaged extends UDisks2 API by exporting several enterprise features (in form of plugins), such as LVM2 and iSCSI. This project is a drop-in replacement for UDisks2, either from D-Bus or binary point of view. The main motivation of this change is to provide the unified D-Bus API for all the clients who are willing to manage LVM2, iSCSI, Btrfs, BCache, LSM and ZRam.

Comment 1 Jan Kurik 2016-05-30 11:53:15 UTC
The Change has been turned into System-Wide Change: https://fedorahosted.org/fesco/ticket/1568#comment:13

Comment 2 Tomas Smetana 2016-07-13 09:44:46 UTC
Since there were no issues discovered during the testing of COPR experimental packges, the new storaged-2.6.2-1 has been built in Rawhide.

Comment 3 Jan Kurik 2016-07-26 05:09:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.