Bug 1347415 - iSCSI install fails in current Rawhide with "The name org.storaged.Storaged was not provided by any .service files"
Summary: iSCSI install fails in current Rawhide with "The name org.storaged.Storaged w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1370409 (view as bug list)
Depends On:
Blocks: F25FinalBlocker 1330055
TreeView+ depends on / blocked
 
Reported: 2016-06-16 18:53 UTC by Adam Williamson
Modified: 2016-09-27 00:39 UTC (History)
8 users (show)

Fixed In Version: lorax-25.15-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 00:39:58 UTC


Attachments (Terms of Use)

Description Adam Williamson 2016-06-16 18:53:44 UTC
When trying to do an iSCSI install in current Fedora Rawhide, anaconda crashes when you click 'Add iSCSI Target...' . anaconda.log shows this traceback:

07:51:51,593 CRIT anaconda: Traceback (most recent call last):

  File "/usr/lib/python3.5/site-packages/blivet/safe_dbus.py", line 147, in call_sync
    DEFAULT_DBUS_TIMEOUT, None)

GLib.GError: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.storaged.Storaged was not provided by any .service files (2)


During handling of the above exception, another exception occurred:


Traceback (most recent call last):

  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/filter.py", line 661, in on_add_iscsi_clicked
    dialog.refresh()

  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/advstorage/iscsi.py", line 171, in refresh
    self._initiatorEntry.set_text(self.iscsi.initiator)

  File "/usr/lib/python3.5/site-packages/blivet/util.py", line 1104, in decorated
    if self.check_avail(onetime=just_onetime):

  File "/usr/lib/python3.5/site-packages/blivet/util.py", line 1092, in check_avail
    self._avail = self._check_avail()

  File "/usr/lib/python3.5/site-packages/blivet/iscsi.py", line 92, in _check_avail
    if not safe_dbus.check_object_available(STORAGED_SERVICE, STORAGED_MANAGER_PATH, MANAGER_IFACE):

  File "/usr/lib/python3.5/site-packages/blivet/safe_dbus.py", line 194, in check_object_available
    intro_data = call_sync(service, obj_path, DBUS_INTRO_IFACE, "Introspect", None)

  File "/usr/lib/python3.5/site-packages/blivet/safe_dbus.py", line 151, in call_sync
    raise DBusCallError(msg)

blivet.safe_dbus.DBusCallError: Failed to call Introspect method on /org/storaged/Storaged/Manager with None arguments: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.storaged.Storaged was not provided by any .service files

you can find details including full logs at https://openqa.fedoraproject.org/tests/22967 .

Proposing as an F25 Final blocker - "The installer must be able to detect (if possible) and install to supported network-attached storage devices."

Comment 1 Vratislav Podzimek 2016-07-11 11:47:05 UTC
This change needs to happen in lorax.

Comment 2 Vratislav Podzimek 2016-07-11 11:47:32 UTC
https://github.com/rhinstaller/lorax/pull/139

Comment 3 Petr Schindler 2016-07-21 09:40:02 UTC
Discussed at 2016-07-20 blocker review meeting: [1]. 

This bug was accepted as Final blocker: This bug violates the final criterion: "The installer must be able to detect (if possible) and install to supported network-attached storage devices." 

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-07-20/f25-blocker-review.2016-07-20-16.00.html

Comment 4 Jan Kurik 2016-07-26 05:11:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 5 Adam Williamson 2016-08-04 21:20:37 UTC
Still broken, the PR has not been +1ed or merged.

Comment 6 Vratislav Podzimek 2016-08-26 08:55:57 UTC
*** Bug 1370409 has been marked as a duplicate of this bug. ***

Comment 7 Vratislav Podzimek 2016-08-26 09:06:38 UTC
(In reply to Adam Williamson from comment #5)
> Still broken, the PR has not been +1ed or merged.

Pushed.

Comment 8 Fedora Update System 2016-09-08 23:40:20 UTC
lorax-25.15-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e7ec643539

Comment 9 Fedora Update System 2016-09-10 07:57:58 UTC
lorax-25.15-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e7ec643539

Comment 10 Adam Williamson 2016-09-13 19:51:49 UTC
This bug does seem fixed by the new lorax in Rawhide. We now crash a bit later:

https://bugzilla.redhat.com/show_bug.cgi?id=1375712

Comment 11 Fedora Update System 2016-09-27 00:39:58 UTC
lorax-25.15-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.