Bug 1337047

Summary: Memory leak in EnumerateActions call results handler (polkit_authority_enumerate_actions_finish) causes massive memory leak in KDE
Product: Red Hat Enterprise Linux 7 Reporter: Marcel Kolaja <mkolaja>
Component: polkitAssignee: Miloslav Trma─Ź <mitr>
Status: CLOSED ERRATA QA Contact: Karel Srot <ksrot>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 7.2CC: alanm, dzhukous, jwright, ksrot, mitr, mkolaja, mostroski, pkis, rdutta
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: polkit-0.112-7.el7_2 Doc Type: Bug Fix
Doc Text:
Previously, the polkit client library did not correctly free memory when listing available actions, which could cause programs to terminate. With this update, the library frees the memory correctly.
Story Points: ---
Clone Of: 1310738 Environment:
Last Closed: 2016-06-23 16:31:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1310738    
Bug Blocks:    

Description Marcel Kolaja 2016-05-18 07:18:19 UTC
This bug has been copied from bug #1310738 and has been proposed
to be backported to 7.2 z-stream (EUS).

Comment 14 errata-xmlrpc 2016-06-23 16:31:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1259