Bug 1310738 - Memory leak in EnumerateActions call results handler (polkit_authority_enumerate_actions_finish) causes massive memory leak in KDE
Summary: Memory leak in EnumerateActions call results handler (polkit_authority_enumer...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: polkit
Version: 7.2
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Miloslav Trmač
QA Contact: Stefan Kremen
Maxim Svistunov
URL:
Whiteboard:
Depends On:
Blocks: 1337047
TreeView+ depends on / blocked
 
Reported: 2016-02-22 15:13 UTC by Alan Matsuoka
Modified: 2016-11-04 07:55 UTC (History)
8 users (show)

Fixed In Version: polkit-0.112-7.el7
Doc Type: Release Note
Doc Text:
Programs no longer run out of memory when repeatedly listing available *polkit* actions Previously, the *polkit* client library did not correctly free memory when listing available actions, which could cause programs to run out of memory and terminate. With this update, the library frees the memory correctly, and programs no longer crash in this scenario.
Clone Of:
: 1337047 (view as bug list)
Environment:
Last Closed: 2016-11-04 07:55:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2529 normal SHIPPED_LIVE polkit bug fix update 2016-11-03 14:16:52 UTC

Description Alan Matsuoka 2016-02-22 15:13:55 UTC
Description of problem:
There is a memory leak in EnumerateActions call results handler that causes KDE 
to leak massive amounts of memory.

Version-Release number of selected component (if applicable):

polkit-0.112-6.el7_2

How reproducible:
User reported slow machine. After checking we noticed KDE was consuming 60% of the available memory.

dhws018# ps auxwf | grep -e kde
wao      30489  0.0 59.0 16842380 9454440 ?    Sl   Oct09   2:40 kdeinit4: kded4 [kdeinit]

Steps to Reproduce:
1. start kde 
2. memory will start to grow over a couple of days
3.

Actual results:

KDE will us up over 60% of available memory

Expected results:
no memory leak.
https://bugs.kde.org/show_bug.cgi?id=271934#c130


Additional info:
https://bugs.freedesktop.org/show_bug.cgi?id=88288

Comment 1 Mark Ostroski 2016-04-13 20:48:16 UTC
This is already fixed for fedora: 
https://bugzilla.redhat.com/show_bug.cgi?id=1180886

Comment 14 errata-xmlrpc 2016-11-04 07:55:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2529.html


Note You need to log in before you can comment on or make changes to this bug.