Bug 1337237

Summary: Alarm status
Product: Red Hat Storage Console Reporter: Lubos Trilety <ltrilety>
Component: UIAssignee: Karnan <kchidamb>
Status: CLOSED ERRATA QA Contact: Lubos Trilety <ltrilety>
Severity: unspecified Docs Contact:
Priority: high    
Version: 2CC: deb, julim, kchidamb, mkudlej, nthomas, sankarshan, sodeb, vsarmila
Target Milestone: ---   
Target Release: 2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-23 19:50:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1344195    

Description Lubos Trilety 2016-05-18 14:56:12 UTC
Description of problem:
When alarm status is displayed clicking on the count will drill down to a filtered list of events/alarms for that entity (in the Events view). However in all cases it shows only events with critical severity. It doesn't make sense especially when the count shows events/alarms with warning severity.

Version-Release number of selected component (if applicable):
rhscon-ceph-0.0.15-1.el7scon.x86_64
rhscon-core-0.0.18-1.el7scon.x86_64
rhscon-ui-0.0.31-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. Have a cluster in warning state, click on number of alerts
2.
3.

Actual results:
Only critical events for the cluster are displayed.

Expected results:
All active events which are count in the sum of alerts are displayed and only them.

Additional info:

Comment 2 Ju Lim 2016-06-07 20:48:15 UTC
The Events view that is shown should always show a listing with filters applied based on the context / trigger.

Comment 3 Lubos Trilety 2016-06-08 10:29:24 UTC
*** Bug 1343577 has been marked as a duplicate of this bug. ***

Comment 4 Lubos Trilety 2016-06-08 10:30:32 UTC
Possible reproduction scenario from BZ 1343577

Steps to Reproduce:
1. Create some cluster
2. Remove some disks from OSD hosts
3. Click on the alerts number

Comment 5 :Deb 2016-06-14 15:18:27 UTC
This should be easy to fix, if the correct course of action is identified (whether to show warning level severity events in the list, or not include them in the count shown - to resolve the discrepancy).

Looking forward for the UX team to give a direction there.

Comment 6 Ju Lim 2016-06-14 19:00:06 UTC
What types of warning level severity events do we have?  Can someone share that list? This is needed to be able to provide guidance.

Comment 7 Karnan 2016-06-21 06:24:56 UTC
There are 5 levels
- info 
- minor
- warning
- major
- critical

When we display even counts in UI,
minor & warning together considered as warning
major & critical considered as critical.

Comment 8 Nishanth Thomas 2016-06-21 10:01:37 UTC
To add the issue mentioned in BZ is already fixed in the last and it works as karnan stated in the above comment

Comment 11 Lubos Trilety 2016-07-22 11:43:22 UTC
Tested on:
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-ui-0.0.48-1.el7scon.noarch
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64

Comment 13 errata-xmlrpc 2016-08-23 19:50:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754