Bug 1339054

Summary: Need to improve remove-brick failure message when the brick process is down.
Product: Red Hat Gluster Storage Reporter: Byreddy <bsrirama>
Component: glusterdAssignee: Atin Mukherjee <amukherj>
Status: CLOSED ERRATA QA Contact: Rajesh Madaka <rmadaka>
Severity: high Docs Contact:
Priority: unspecified    
Version: rhgs-3.1CC: amukherj, nchilaka, rhinduja, rhs-bugs, rmadaka, sheggodu, storage-qa-internal, vbellur
Target Milestone: ---Keywords: ZStream
Target Release: RHGS 3.4.0   
Hardware: x86_64   
OS: Linux   
Whiteboard: rebase
Fixed In Version: glusterfs-3.12.2-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1422624 (view as bug list) Environment:
Last Closed: 2018-09-04 06:29:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1422624, 1423406, 1438325, 1503134    

Description Byreddy 2016-05-24 04:35:27 UTC
Description of problem:
If we try to remove offline brick, the operation is failing with error message "volume remove-brick start: failed: Found stopped brick <hostname>:/bricks/brick1/a1" and this condition is added newly in 3.7.9-6 build.

Currently we have use force option to remove the offline brick and same thing is expected in the failure message to use force option to remove the offline brick to guide the user.

With this users will know the how to remove the offline brick.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create a simple volume of any type and start it
2. Kill one of the volume brick
3. Try to remove the killed brick (offline brick) 
4. Check the brick failure error message //message won't convey how to remove the brick.

Failure message getting:
]# gluster volume remove-brick Dis <hostname>:/bricks/brick1/a1 start
volume remove-brick start: failed: Found stopped brick <hostname>:/bricks/brick1/a1

Actual results:
Failure is not saying how to remove the offline brick.

Expected results:
Failure message need to have force option help message to remove the offline brick.

Additional info:

Comment 5 Atin Mukherjee 2017-02-16 13:33:35 UTC
Upstream patch : https://review.gluster.org/16630

Comment 8 Rajesh Madaka 2018-02-20 12:08:08 UTC
Verified this bug for distributed volume and distributed replica volume with 3 node cluster.

Verified scenario:

  -> Created Distributed volume with each brick from each node in 3 node cluster.
  -> Killed one of the volume brick
  -> And tried remove the offline brick using "remove-brick" command
  -> Command thrown proper error message like below
      "volume remove-brick start: failed: Found stopped brick Use force option to remove the offline brick"

-> Above process tried for distributed replica volume also got proper error message.

Verified version:


Moving this bug to verified state

Comment 11 errata-xmlrpc 2018-09-04 06:29:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.