Bug 1422624 - Need to improve remove-brick failure message when the brick process is down.
Summary: Need to improve remove-brick failure message when the brick process is down.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gaurav Yadav
QA Contact:
URL:
Whiteboard:
Depends On: 1339054
Blocks: 1423406 1438325
TreeView+ depends on / blocked
 
Reported: 2017-02-15 17:25 UTC by Gaurav Yadav
Modified: 2017-05-30 18:43 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1339054
: 1423406 1438325 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:43:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Gaurav Yadav 2017-02-15 17:25:11 UTC
+++ This bug was initially created as a clone of Bug #1339054 +++

Description of problem:
======================
If we try to remove offline brick, the operation is failing with error message "volume remove-brick start: failed: Found stopped brick <hostname>:/bricks/brick1/a1" and this condition is added newly in 3.7.9-6 build.

Currently we have use force option to remove the offline brick and same thing is expected in the failure message to use force option to remove the offline brick to guide the user.

With this users will know the how to remove the offline brick.


Version-Release number of selected component (if applicable):
=============================================================
glusterfs-3.7.9-6


How reproducible:
=================
Always


Steps to Reproduce:
===================
1. Create a simple volume of any type and start it
2. Kill one of the volume brick
3. Try to remove the killed brick (offline brick) 
4. Check the brick failure error message //message won't convey how to remove the brick.


Failure message getting:
=======================
]# gluster volume remove-brick Dis <hostname>:/bricks/brick1/a1 start
volume remove-brick start: failed: Found stopped brick <hostname>:/bricks/brick1/a1


Actual results:
================
Failure is not saying how to remove the offline brick.

Expected results:
=================
Failure message need to have force option help message to remove the offline brick.

Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-05-24 00:35:31 EDT ---

This bug is automatically being proposed for the current z-stream release of Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-07-04 04:53:19 EDT ---

This bug is automatically being proposed for the current z-stream release of Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from Rejy M Cyriac on 2016-09-17 12:33:32 EDT ---

Moving BZ to a transitional component in preparation for removing the 'glusterd' sub-component at the 'glusterd' component

--- Additional comment from Rejy M Cyriac on 2016-09-17 12:46:25 EDT ---

Moving BZ back to the 'glusterd' component after removal of the 'glusterd' sub-component

Comment 1 Worker Ant 2017-02-16 07:47:07 UTC
REVIEW: https://review.gluster.org/16630 (glusterd : Fix for error message while removing brick) posted (#1) for review on master by Gaurav Yadav (gyadav@redhat.com)

Comment 2 Worker Ant 2017-02-16 08:49:53 UTC
REVIEW: https://review.gluster.org/16630 (glusterd : Fix for error message while removing brick) posted (#2) for review on master by Gaurav Yadav (gyadav@redhat.com)

Comment 3 Worker Ant 2017-02-17 09:56:01 UTC
REVIEW: https://review.gluster.org/16630 (glusterd : Fix for error message while removing brick) posted (#3) for review on master by Gaurav Yadav (gyadav@redhat.com)

Comment 4 Worker Ant 2017-02-17 09:58:55 UTC
REVIEW: https://review.gluster.org/16630 (glusterd : Fix for error message while removing brick) posted (#4) for review on master by Gaurav Yadav (gyadav@redhat.com)

Comment 5 Worker Ant 2017-02-17 14:47:37 UTC
COMMIT: https://review.gluster.org/16630 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 64637d040d7f63ef6af6588ae17a557ad0229710
Author: Gaurav Yadav <gyadav@redhat.com>
Date:   Thu Feb 16 13:02:20 2017 +0530

    glusterd : Fix for error message while removing brick
    
    When remove-brick command is issued to a offline brick, glusterd
    error out the operation with message -: "volume remove-brick start:
    failed: Found stopped brick <hostname>:".
    
    With this fix while removing brick, error message is modified
    to "volume remove-brick start: failed: Found stopped brick
    <brick path>. Use force option to remove the brick"
    
    Change-Id: Id40a02fc38cdb526c4629de262967fe2383febe4
    BUG: 1422624
    Signed-off-by: Gaurav Yadav <gyadav@redhat.com>
    Reviewed-on: https://review.gluster.org/16630
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 6 Shyamsundar 2017-05-30 18:43:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.