Bug 134306

Summary: mod_perl dependency problem
Product: [Fedora] Fedora Reporter: Chris Underhill <redhat-bugzilla>
Component: mod_perlAssignee: Chip Turner <cturner>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: michal, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-10 03:26:05 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 130887    

Description Chris Underhill 2004-10-01 04:50:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10 Mnenhy/

Description of problem:
up2date fails with the error:

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:
Unresolvable chain of dependencies:
mod_perl  1.99_16-2                      requires perl(Data::Flow)
mod_perl  1.99_16-2                      requires perl(Module::Build)

yum upgrade fails with:

Loop Number: 2
Processing Dependency: perl(Data::Flow) for package: mod_perl
Processing Dependency: perl(Module::Build) for package: mod_perl
Finished Dependency Resolution
Error: missing dep: perl(Data::Flow) for pkg mod_perl
Error: missing dep: perl(Module::Build) for pkg mod_perl

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run up2date or yum upgrade
2. Look at the output


Actual Results:  Update failed

Expected Results:  Update succeeded

Additional info:

Current version installed of mod_perl is 1.99_12-3
System is FC3T2 plus all updates up to 2004/09/29
Comment 1 Warren Togami 2004-10-09 18:17:46 EDT
*** Bug 134447 has been marked as a duplicate of this bug. ***
Comment 2 Warren Togami 2004-10-09 18:19:54 EDT
I believe this is solved in current rawhide.  Please confirm.
Comment 3 Michal Jaegermann 2004-10-09 20:26:13 EDT
AFAICT this is indeed solved; at least with mod_perl-1.99_16-3.