Bug 135022

Summary: up2date no longer works with rpm-libs-4.3.2-10 installed
Product: [Fedora] Fedora Reporter: Jef Spaleta <jspaleta>
Component: up2dateAssignee: Adrian Likins <alikins>
Status: CLOSED DUPLICATE QA Contact: Fanny Augustin <fmoquete>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: barryn
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 14:06:13 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 130887    

Description Jef Spaleta 2004-10-07 23:37:33 EDT
Description of problem:
seems there as been an internal change to rpm-libs as of todays
rawhide updates affecting both yum and up2date dependancy resolution.  

Example:
up2date gnumeric   
will get stuck in dep resolution with rpm-libs-4.3.2-10.

Yum Bug Reference: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=135008#c7


How reproducible:
When using up2date to install a package that needs an addition
dependancy to be installed as well, up2date will get stuck at the
dependancy resolution stage.

So up2date gnumeric fails for me because i do not have libgda or
libgnomedb installed

but if i do  up2date gnumeric libgda libgnomedb  that will succeed
because up2date doesnt have to look up additional packages to fullfil
deps.

-jef
Comment 1 Jeremy Katz 2004-10-12 14:48:15 EDT

*** This bug has been marked as a duplicate of 135008 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.