Bug 135008 - yum dies with an error on certain packages
yum dies with an error on certain packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 135022 135026 135201 (view as bug list)
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-07 18:31 EDT by Okke Timm
Modified: 2014-01-21 17:50 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 11:41:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum -d 7 install gnumeric (1.01 KB, text/plain)
2004-10-07 22:53 EDT, Jef Spaleta
no flags Details
rpm 4.3.2 patch (729 bytes, patch)
2004-10-11 11:24 EDT, Paul Nasrat
no flags Details | Diff

  None (edit)
Description Okke Timm 2004-10-07 18:31:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 
7.54  [de]

Description of problem:
"yum install" dies on some packages with an error after the 
dependency check.

Version-Release number of selected component (if applicable):
yum-2.1.6-1

How reproducible:
Always

Steps to Reproduce:
1. yum -d 6 install gnumeric
2.
3.
    

Actual Results:  Yum Version: 2.1.6
COMMAND: yum -d 6 install gnumeric 
Installroot: /
Setting up Install Process
Setting up Repo:  development
Baseurl(s) for repo: ['ftp://download.fedora.redhat.com/pub/fedora/
linux/core/development/i386/']
repomd.xml                100% |=========================| 1.1 kB    
00:00     
Reading repository metadata in from local files
Setting up Package Sacks
developmen: ################################################## 3423/
3423
Reading Local RPMDB
reduced installs :
   gnumeric.i386 1:1.2.13-6
Resolving Dependencies
1097188199.25
Adding Package gnumeric - 1:1.2.13-6.i386 in mode i
Package gnumeric.i386 1:1.2.13-6 set to be installed
# of Deps = 12
gnumeric requires: libgnomeui>= 2.4.0
Processing Dependency: libgnomeui>= 2.4.0 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libgnomecanvas-2.so.0
Processing Dependency: libgnomecanvas-2.so.0 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libgnomeui-2.so.0
Processing Dependency: libgnomeui-2.so.0 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libgsf>= 1.9.0
Processing Dependency: libgsf>= 1.9.0 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libgda-2.so.1
Processing Dependency: libgda-2.so.1 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libgsf-1.so.1
Processing Dependency: libgsf-1.so.1 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libgnomeprintui22>= 2.3.0
Processing Dependency: libgnomeprintui22>= 2.3.0 for package: 
gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libgnomedb-2.so.3
Processing Dependency: libgnomedb-2.so.3 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libgnomeprint-2-2.so.0
Processing Dependency: libgnomeprint-2-2.so.0 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libgsf-gnome-1.so.1
Processing Dependency: libgsf-gnome-1.so.1 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libbonoboui-2.so.0
Processing Dependency: libbonoboui-2.so.0 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
gnumeric requires: libgnomeprintui-2-2.so.0
Processing Dependency: libgnomeprintui-2-2.so.0 for package: gnumeric
Requiring package gnumeric-1.2.13-6.i386 not in transaction set       
                            nor in rpmdb
miss = 12
conf = 0
CheckDeps = 0
Finished Dependency Resolution
Dependency Process ending
Error: Requiring package gnumeric-1.2.13-6.i386 not in transaction 
set                                   nor in rpmdb

Expected Results:  yum should install the package.

Additional info:
Comment 1 Jef Spaleta 2004-10-07 18:46:39 EDT
I can confirm this 'yum install whatever' bug:
same problem happens when i use any mirror
same problem happens when i revert back to yum 2.1.5

I'm seeing similar situation when i try to use 'yum remove'
and the dependancy lookup finds an extra dependancy.
yum remove dosfstools 
for example finds mkbootdisk as a dependancy but then gives a similar
error about not being in the transaction set.
yum remove mkbootdisk 
seems to work as expected.

updating packages seems to be unaffected.

-jef
Comment 2 Seth Vidal 2004-10-07 19:30:29 EDT
I can't replicate this at all. When did it start happening?

Can you revert the version of rpm from before today and see if it
still occurs there?

Thanks
Comment 3 Jef Spaleta 2004-10-07 22:37:51 EDT
I reverted back to rpm-4.3.2-8 and even did rpm --rebuilddb
same sort of thing for yum install gnumeric.
both yum 2.1.5 and 2.1.6

i looked in /var/log/messages too for maybe some weird new selinux
policy messages...nada.

And as per dicussion... this only happens with packages that have a
dependancy that needs to be installed
yum install zsh-html   works as expected

-jef



Comment 4 Jef Spaleta 2004-10-07 22:53:23 EDT
Created attachment 104920 [details]
yum -d 7 install gnumeric
Comment 5 Jef Spaleta 2004-10-07 23:08:13 EDT
bah.... i missed rpm-libs when i reverted..

with rpm-libs-4.3.2-10 the problem occurs
with rpm-libs-4.3.2-8 or -5 installed the problem goes away

happy hunting

-jef 
Comment 6 Seth Vidal 2004-10-07 23:11:34 EDT
rpm 4.3.2-10 changed the ts.check() respone tuple in an incompatible
way with how yum determines dependencies. I think it's a little late
in the dev cycle for api-breaking changes.
Comment 7 Jef Spaleta 2004-10-07 23:27:13 EDT
and to make things even more interesting....

up2date seems to have similar behavior

with rpm-libs-4.3.2-10  installed
up2date gnumeric    will get stuck at resolving dependancies... and i
mean stuck

up2date gnumeric libgda libgnomedb  as one command works
just like yum install gnumeric libgda libgnomedb   works

i revert back to rpm-libs-4.3.2-8  and both yum and up2date work as
expected.

I'm probably going to file this against up2date and reference this report

-jef
Comment 8 Féliciano Matias 2004-10-08 11:49:33 EDT
A copy of 4.3.2-8 is available here :
http://feliciano.matias.free.fr/rpm/
Comment 9 Seth Vidal 2004-10-10 00:12:06 EDT
*** Bug 135201 has been marked as a duplicate of this bug. ***
Comment 10 Paul Nasrat 2004-10-11 11:24:36 EDT
Created attachment 105015 [details]
rpm 4.3.2 patch

The above patch tested against rpm 4.3.2-11 + patch reverts the rpm-python
behaviour R.A to R only in ts.check tuple.  Medium term (rpm 4.4) we need to
come up with a better fix to handle biarch deps gracefully

Also commited to HEAD, Jeff can you check and put on rpm 4.3 branch - cheers.
Comment 11 Paul Nasrat 2004-10-11 11:26:26 EDT
Jeff see previous comment - I meant to attach and reassign in one
operation.
Comment 12 Jeff Johnson 2004-10-11 11:41:28 EDT
Added in rpm-4.3.2-12. Thanks for the patch.
Comment 13 Jeremy Katz 2004-10-12 14:48:29 EDT
*** Bug 135026 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2004-10-12 14:48:33 EDT
*** Bug 135022 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.