Bug 1350875

Summary: etcd adding new member fails
Product: Red Hat Enterprise Linux 7 Reporter: Alexander Koksharov <akokshar>
Component: etcdAssignee: Jan Chaloupka <jchaloup>
Status: CLOSED ERRATA QA Contact: atomic-bugs <atomic-bugs>
Severity: urgent Docs Contact: Yoana Ruseva <yruseva>
Priority: high    
Version: 7.2CC: agoldste, akokshar, aos-bugs, asogukpi, atomic-bugs, eparis, erich, jamills, jcajka, jchaloup, jdetiber, jeder, jokerman, mmccomas, pep, rhowe, sghosh, sttts, tis, tstclair, ypu, yruseva
Target Milestone: rcKeywords: Extras
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: etcd-2.3.7-4.el7 Doc Type: Known Issue
Doc Text:
The etcd packages have been upgraded to extend `etcdctl backup` command with options to reuse backup of previous etcd member.
Story Points: ---
Clone Of: 1328482 Environment:
Last Closed: 2016-09-15 08:29:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1328482    
Bug Blocks: 1186913, 1303130, 1267746, 1361733, 1367035    

Comment 44 Yoana Ruseva 2016-09-08 19:33:27 UTC
Jan, is this a known issue that was fixed? The Doc Text looks like an enhancement. It is part of the erratum description at the moment:

https://errata.devel.redhat.com/errata/details/24502

If it really is a known issue still, I'll add it to the Known Issues in the Release Notes here:

https://access.qa.redhat.com/documentation/en/red-hat-enterprise-linux-atomic-host/7/single/release-notes/#known_issues

Comment 45 Jan Chaloupka 2016-09-09 12:02:19 UTC
It is known issue and enhancement at the same time. However, as it already affects current customers and in some cases make the etcd unusable, it more classifies as known issue.

Comment 47 errata-xmlrpc 2016-09-15 08:29:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1828.html