Bug 1351292

Summary: Impress: Instead of showing "Slide Master" view, "Normal" view is shown
Product: [Fedora] Fedora Reporter: Christian Stadelmann <fedora>
Component: libreofficeAssignee: David Tardon <dtardon>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: caolanm, dtardon, erack, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-19 16:09:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Christian Stadelmann 2016-06-29 15:54:25 UTC
Version-Release number of selected component (if applicable):
libreoffice-5.1.4.2-3.fc24.x86_64
gtk3-3.20.6-1.fc24.x86_64

How reproducible:
often (~50% of all tries)

Steps to Reproduce:
1. open LibreOffice Impress
2. note your current view
3. from "View" menu, select "Slide Master"
4. note your current view

Actual results:
Sometimes (~50% of the time I tried), instead of showing "Slide Master" the view goes back to "Normal".

Expected results:
When I select "Slide Master", LibreOffice should show "Slide Master".

Additional info:
Happens on both x11 and wayland Gdk backend.
If you're running on wayland and LibreOffice just exits for no reason, you're probably running into bug #1351224.

This issue is also present with SAL_USE_VCLPLUGIN=gen set.

Note: I originally reported this as a comment on bug https://bugzilla.redhat.com/show_bug.cgi?id=1343752#c7

Comment 1 David Tardon 2016-06-30 06:23:39 UTC
This happens when switching between different shells; in terms of views, it is, e.g., Slide Sorter -> Slide Master or Handout Master -> Normal.

A naive attempt at delaying the setting of page mode after the asynchronous UI update has finished does not work, because the page mode is reset from yet another place after that. I need to dig deeper.

Comment 2 Fedora Update System 2016-07-18 15:21:46 UTC
libreoffice-5.1.4.2-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cb25df449f