Bug 1343752 - wrong radiobutton and checkbutton behavior in "view" menu
Summary: wrong radiobutton and checkbutton behavior in "view" menu
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Tardon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-07 20:09 UTC by Christian Stadelmann
Modified: 2016-06-29 13:54 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-06-27 18:25:16 UTC


Attachments (Terms of Use)
A backtrace from gdb attached to libreoffice breaking on g_strerror (96.17 KB, text/plain)
2016-06-25 10:57 UTC, Christian Stadelmann
no flags Details

Description Christian Stadelmann 2016-06-07 20:09:46 UTC
Description of problem:
It is possible to have multiple radio buttons selected in the "view" menu.

Version-Release number of selected component (if applicable):
libreoffice-5.1.4.1-1.fc24.x86_64
gtk3-3.20.6-1.fc24.x86_64
abrt-2.8.1-1.fc24.x86_64
libreport-2.7.1-1.fc24.x86_64

How reproducible:
always with Gtk3 backend

Steps to Reproduce:
1. open libreoffice
2. open a new impress (presentation) document
3. in "View" menu, select any other radio button but "Normal"

Actual results:
For some radio buttons, two of them are selected at the same time. This affects e.g: Normal+Outline or Notes+Slide Sorter, Normal+Slide Sorter, …
For some other combinations of radio buttons, it just takes very long to change the selection. When hiding the menu and then showing it again, you see the previous selection.

Expected results:
In a group of radio buttons, exactly one button must be selected, not more.
Menu should immediately react to changes.

Comment 1 Christian Stadelmann 2016-06-07 20:46:50 UTC
This is also true for CheckButtons.
1. have a selected CheckButton
2. unselect it
3. open the menu again

What happens:
CheckButton shows being selected but behaves correctly (as if it were unselected)

What should happen:
CheckButton should present its state.

This issue is also present with other backends such as SAL_USE_VCLPLUGIN=kde4.

Comment 2 David Tardon 2016-06-08 11:12:03 UTC
Blah. Apparently the handling of normal vs. master modes has been redone, but the special code in the menu for switching from a master mode back to normal has stayed as it was...

Comment 3 David Tardon 2016-06-08 11:31:33 UTC
Actually the DisplayModeToolbarMenu was added for this change. So it's likely just buggy...

Comment 4 Fedora Update System 2016-06-17 06:33:51 UTC
libreoffice-5.1.4.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-eff96af205

Comment 5 Fedora Update System 2016-06-24 05:53:36 UTC
libreoffice-5.1.4.2-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-79961c949b

Comment 6 Fedora Update System 2016-06-25 00:31:31 UTC
libreoffice-5.1.4.2-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-79961c949b

Comment 7 Christian Stadelmann 2016-06-25 10:57 UTC
Created attachment 1172226 [details]
A backtrace from gdb attached to libreoffice breaking on g_strerror

Still broken.

Now, when selecting "View" → "Slide Sorter", LibreOffice often just exits after printing this warning:

(soffice:10680): Gdk-WARNING **: Error 71 (Protocol error) dispatching to Wayland display.

This also happens on some other items in this menu, but I can't exactly tell when. Please note that I'm seeing this in firefox (wayland builds) too, see bug #1350060. I've attached a backtrace for this by setting a breakpoint to g_strerror in https://github.com/GNOME/gtk/blob/master/gdk/wayland/gdkeventsource.c#L197

Other than that, when selecting "View" → "Slide Master", it often gets back to "View" → "Normal".

Comment 8 Fedora Update System 2016-06-25 20:12:06 UTC
libreoffice-5.1.4.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2bf872a06

Comment 9 Fedora Update System 2016-06-26 19:26:22 UTC
libreoffice-5.1.4.2-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2bf872a06

Comment 10 David Tardon 2016-06-27 07:18:16 UTC
(In reply to Christian Stadelmann from comment #7)
> Created attachment 1172226 [details]
> A backtrace from gdb attached to libreoffice breaking on g_strerror
> 
> Still broken.
> 
> Now, when selecting "View" → "Slide Sorter", LibreOffice often just exits
> after printing this warning:
> 
> (soffice:10680): Gdk-WARNING **: Error 71 (Protocol error) dispatching to
> Wayland display.
> 
> This also happens on some other items in this menu, but I can't exactly tell
> when. Please note that I'm seeing this in firefox (wayland builds) too, see
> bug #1350060. I've attached a backtrace for this by setting a breakpoint to
> g_strerror in
> https://github.com/GNOME/gtk/blob/master/gdk/wayland/gdkeventsource.c#L197

I haven't seen that locally. Anyway, since it also happens in Firefox, it's likely a Gtk bug.

> 
> Other than that, when selecting "View" → "Slide Master", it often gets back
> to "View" → "Normal".

That's a different problem.

Comment 11 Fedora Update System 2016-06-27 18:24:56 UTC
libreoffice-5.1.4.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Christian Stadelmann 2016-06-27 19:47:21 UTC
(In reply to David Tardon from comment #10)
> (In reply to Christian Stadelmann from comment #7)
> > Created attachment 1172226 [details]
> > A backtrace from gdb attached to libreoffice breaking on g_strerror
> > […]
> I haven't seen that locally. Anyway, since it also happens in Firefox, it's
> likely a Gtk bug.

I've reported that upstream in https://bugzilla.gnome.org/show_bug.cgi?id=768111

Comment 13 Christian Stadelmann 2016-06-29 13:54:28 UTC
(In reply to Christian Stadelmann from comment #12)
> (In reply to David Tardon from comment #10)
> > (In reply to Christian Stadelmann from comment #7)
> > > Created attachment 1172226 [details]
> > > A backtrace from gdb attached to libreoffice breaking on g_strerror
> > > […]
> > I haven't seen that locally. Anyway, since it also happens in Firefox, it's
> > likely a Gtk bug.
> 
> I've reported that upstream in
> https://bugzilla.gnome.org/show_bug.cgi?id=768111

Upstream claims it is a LibreOffice bug. I've opened bug #1351224 for that.


(In reply to David Tardon from comment #10)
> (In reply to Christian Stadelmann from comment #7)
> > Other than that, when selecting "View" → "Slide Master", it often gets back
> > to "View" → "Normal".
> 
> That's a different problem.

Ok, opening a new bug report for this too.


Note You need to log in before you can comment on or make changes to this bug.