Bug 135668

Summary: mod_python should require same python version as at building time
Product: [Fedora] Fedora Reporter: Robert Scheck <redhat-bugzilla>
Component: mod_pythonAssignee: Mihai Ibanescu <mihai.ibanescu>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dgunchev
Target Milestone: ---Keywords: EasyFix
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 3.1.3-7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-12-12 16:04:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 123268, 136451    

Description Robert Scheck 2004-10-14 09:18:09 UTC
Description of problem:
mod_python should require same python version as at building time,
this isn't the case currently.

Version-Release number of selected component (if applicable):
mod_python-3.1.3-5

Actual results / Expected results:
The line

  "Requires: httpd >= 2.0.40"

should be changed to: 

  "Requires: httpd >= 2.0.40, python >= %(%{__python} -c "import sys; print sys.version[:3]")"

which would solve this report.

Comment 1 Robert Scheck 2004-12-12 16:04:29 UTC
Solved with 3.1.3-7, closing now.