This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 135668 - mod_python should require same python version as at building time
mod_python should require same python version as at building time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_python (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
: EasyFix
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-10-14 05:18 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.1.3-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-12 11:04:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-10-14 05:18:09 EDT
Description of problem:
mod_python should require same python version as at building time,
this isn't the case currently.

Version-Release number of selected component (if applicable):
mod_python-3.1.3-5

Actual results / Expected results:
The line

  "Requires: httpd >= 2.0.40"

should be changed to: 

  "Requires: httpd >= 2.0.40, python >= %(%{__python} -c "import sys; print sys.version[:3]")"

which would solve this report.
Comment 1 Robert Scheck 2004-12-12 11:04:29 EST
Solved with 3.1.3-7, closing now.

Note You need to log in before you can comment on or make changes to this bug.