Bug 1362271

Summary: Constant lookup wasn't working properly
Product: Red Hat CloudForms Management Engine Reporter: Chris Pelland <cpelland>
Component: ProvisioningAssignee: Brandon Dunne <bdunne>
Status: CLOSED ERRATA QA Contact: Shveta <sshveta>
Severity: high Docs Contact:
Priority: high    
Version: 5.6.0CC: bdunne, dajohnso, jhardy, obarenbo
Target Milestone: GAKeywords: ZStream
Target Release: 5.6.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 5.6.1.2 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1362269 Environment:
Last Closed: 2016-08-18 18:00:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Chris Pelland 2016-08-01 19:14:51 UTC
+++ This bug was initially created as a clone of Bug #1362269 +++

Error:

irb(main):001:0> MiqProvisionWorkflow.class_for_platform("vmware")
# INCORRECT
=> ManageIQ::Providers::CloudManager::ProvisionWorkflow
# CORRECT
=> ManageIQ::Providers::Vmware::InfraManager::ProvisionWorkflow

Comment 2 Brandon Dunne 2016-08-02 14:23:11 UTC
Backported to darga from https://github.com/ManageIQ/manageiq/pull/10102

Comment 4 Shveta 2016-08-12 19:07:18 UTC
irb(main):001:0> MiqProvisionWorkflow.class_for_platform("vmware")
=> ManageIQ::Providers::Vmware::InfraManager::ProvisionWorkflow

Create catalog item for type Vmware does not give any error on Request Info tab.

verified in 5.6.1.2.20160810181333_8ba817b

Comment 6 errata-xmlrpc 2016-08-18 18:00:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2016-1634.html