Bug 1375942

Summary: qemu on f25 ppc64le failed with "failed to find romfile efi-virtio.rom
Product: [Fedora] Fedora Reporter: Menanteau Guy <menantea>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED DEFERRED QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: amit.shah, berrange, cfergeau, crobinso, dwmw2, itamar, menantea, pbonzini, rjones, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64le   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-10-19 13:58:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1071880    

Description Menanteau Guy 2016-09-14 09:47:52 UTC
I am trying to create VM on a baremetal with f25 ppc64le without success.
I am not able to get rid of this error:
failed to find romfile "efi-virtio.rom"

When I use virt-install:
virt-install --machine pseries --name f25_ppc64le_alpha1.2 --hvm --virt-type kvm --arch ppc64 --boot cdrom,hd --network bridge=virbr0,model=virtio-net-pci,mac=c0:ff:ee:00:00:51 --disk path=/var/lib/libvirt/images/hd.qcow2,size=10,format=qcow2,bus=virtio,cache=none --memory 4096 --vcpus sockets=1,cores=1,threads=1 --cdrom /var/lib/libvirt/images/Fedora-Server-dvd-ppc64le-25-Alpha-1.2.iso

error:
2016-09-14T09:38:39.406194Z qemu-system-ppc64: -device virtio-net-pci,netdev=hostnet0,id=net0,mac=c0:ff:ee:00:00:51,bus=pci.0,addr=0x1: failed to find romfile "efi-virtio.rom"

Same thing if I run virsh defien and virsh start:

error: qemu-system-ppc64: -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:37:08:f6,bus=pci.0,addr=0x2: failed to find romfile "efi-virtio.rom"

When I set a bridge br0 (different from the virbr0) and I use qemu:
/usr/bin/qemu-system-ppc64 -name /root -enable-kvm -M pseries -smp 4 -m 4G -nographic -nodefaults -monitor stdio -serial pty -device virtio-net-pci,netdev=net10051,mac=c0:ff:ee:00:00:51 -netdev bridge,br=br0,id=net10051 -hda /var/lib/libvirt/images/hd.qcow2 --cdrom /var/lib/libvirt/images/Fedora-Server-dvd-ppc64le-25-Alpha-1.2.iso -S

error:
qemu-system-ppc64: -device virtio-net-pci,netdev=net10051,mac=c0:ff:ee:00:00:51: failed to find romfile "efi-virtio.rom"

rpm -qa | grep qemu
qemu-common-2.7.0-0.2.rc3.fc25.ppc64le
qemu-img-2.7.0-0.2.rc3.fc25.ppc64le
qemu-kvm-2.7.0-0.2.rc3.fc25.ppc64le
libvirt-daemon-driver-qemu-2.1.0-1.fc25.ppc64le
qemu-system-ppc-2.7.0-0.2.rc3.fc25.ppc64le

baremetal have been set with iso: 
https://download.fedoraproject.org/pub/fedora-secondary/releases/test/25_Alpha//Server/ppc64le/iso/Fedora-Server-dvd-ppc64le-25-Alpha-1.2.iso 
+ dnf updates

Comment 1 Cole Robinson 2016-10-14 16:13:56 UTC
Are you still seeing this with latest packages? Did you find a workaround? I'm trying to understand why qemu is throwing that error... don't know why it cares about the efi pxe rom for ppc64

efi-virtio.rom file is provided by qemu-system-x86, maybe that's a mistake?

Comment 2 Menanteau Guy 2016-10-19 13:01:17 UTC
Hi Cole, sorry for the delay. 
I am not able to recreate the poblem with qemu-2.7.0-3.fc25 on ppc64le bare metal machine installed with the latest f25 nightly image.

Note that qemu-system-x86 is installed on the machine. Problem could have been resolved somehow because of correction of https://bugzilla.redhat.com/show_bug.cgi?id=1373576

Anyway, everything seems ok now. Thanks

Comment 3 Cole Robinson 2016-10-19 13:58:17 UTC
Thanks, please reopen if you reproduce at some point