Bug 1373576 - Unable to install qemu-2:2.7.0-0.2.rc3 on fc25 Alpha1.2 ppc64le
Summary: Unable to install qemu-2:2.7.0-0.2.rc3 on fc25 Alpha1.2 ppc64le
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 24
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1368277 (view as bug list)
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-09-06 15:51 UTC by Menanteau Guy
Modified: 2016-10-18 15:50 UTC (History)
11 users (show)

Fixed In Version: qemu-2.6.2-2.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-18 15:50:12 UTC


Attachments (Terms of Use)

Description Menanteau Guy 2016-09-06 15:51:52 UTC
I set a VM machine with Fedora-Server-dvd-ppc64le-25-Alpha-1.2.iso
I did an update and then try to install qemu.

It fails with:
dnf install qemu
Last metadata expiration check: 2:02:14 ago on Tue Sep  6 09:39:27 2016.
Error: nothing provides edk2-ovmf needed by qemu-system-x86-2:2.7.0-0.2.rc3.fc25.ppc64le

Note that this problem is also present on ppc64 (big endian)

Comment 1 Cole Robinson 2016-09-08 19:03:42 UTC
*** Bug 1368277 has been marked as a duplicate of this bug. ***

Comment 2 Cole Robinson 2016-09-08 19:57:49 UTC
edk2 package has ExclusiveArch which excludes ppc. Parts of the edk2 build system choke on it, largely because edk2 has no ppc support so it doesn't make a lot of sense for the build system to support it. Anyways, we can work around it in the qemu spec I think

Comment 3 Cole Robinson 2016-10-03 15:32:00 UTC
This is fixed now in 2.7.0-1, but it seems like there's related issues in bug 1375942

Comment 4 Cole Robinson 2016-10-14 16:07:16 UTC
Reopened because we need the same fix for f23 and f24

Comment 5 Fedora Update System 2016-10-16 23:51:39 UTC
qemu-2.6.2-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a56fb613a8

Comment 6 Fedora Update System 2016-10-18 15:50:12 UTC
qemu-2.6.2-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.