Bug 1376638

Summary: rescue mode cannot mount a default Fedora install
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: anacondaAssignee: Vendula Poncova <vponcova>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 26CC: anaconda-maint-list, awilliam, g.kaviyarasu, gmarr, jonathan, menantea, mkolman, robatino, vanmeeuwen+fedora, vponcova
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: AcceptedBlocker
Fixed In Version: anaconda-26.21.1-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-04-06 20:22:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1349186    

Description Adam Williamson 2016-09-16 02:34:40 UTC
Reproduction is super easy: download https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20160914.n.0/compose/Server/x86_64/iso/Fedora-Server-netinst-x86_64-Rawhide-20160914.n.0.iso , do a completely stock install with it, then boot to rescue mode and select 1) Continue . It will report "You don't have any Linux partitions. The system will reboot automatically when you exit from the shell."

This does not happen with the 20160912.n.0 Fedora 25 nightly (most recent successful compose), it's Rawhide-only.

A dbus warning shows up which does not show up in F25, I dunno if it's related, though:

(process: 1372): GLib-GIO-CRITICAL **: g_dbus_connection_call_sync_internal: assertion 'object_path != NULL && g_variant_is_object_path (object_path)' failed

The new openQA rescue mode test caught this - it tests with an encrypted install, but I tested manually with a non-encrypted install and it's also affected.

Comment 1 Adam Williamson 2016-09-16 02:35:50 UTC
Proposing as an F26 Beta blocker: "The rescue mode of the installer must start successfully and be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations." If this shows up in F25 later, it'll be an F25 blocker.

Comment 2 Adam Williamson 2016-12-05 22:52:45 UTC
This is still valid as of 2016-12-05, see e.g.:

https://openqa.fedoraproject.org/tests/50615

(the openQA test tests with an encrypted install, but it's the same bug).

Comment 3 Vendula Poncova 2017-01-04 16:10:22 UTC
I have tested it with the latest rawhide (https://kojipkgs.fedoraproject.org/compose/rawhide/latest-Fedora-Rawhide/compose/Server/x86_64/iso/Fedora-Server-netinst-x86_64-Rawhide-20170104.n.0.iso) and it seems to work correctly.

Does the test still fail?

Comment 4 Adam Williamson 2017-01-04 16:19:29 UTC
Lately it's failing intermittently:

https://openqa.fedoraproject.org/tests/53741#previous
https://openqa.fedoraproject.org/tests/53742#previous

try it a few times?

Comment 5 Geoffrey Marr 2017-01-09 18:24:15 UTC
Discussed during the 2017-01-09 blocker review meeting: [1]

The decision to delay the classification of this as a bug was made as the recent findings on this bug have changed since it was first submitted, so time for manual testing is being made before a classification is made.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-01-09/f26-blocker-review.2017-01-09-17.00.txt

Comment 6 Menanteau Guy 2017-01-25 14:54:44 UTC
This problem is also present on pppc64 and ppc64le rawhide iso.
I tried several times (5) with Fedora-Server-dvd-ppc64le-Rawhide-20170125.n.0.iso without any success.

Comment 7 Geoffrey Marr 2017-02-13 20:06:42 UTC
Discussed during the 2017-02-13 blocker review meeting: [1]

The decision was made to classify this bug as an AcceptedBlocker as it violates the following Beta criteria:

"The rescue mode of the installer must start successfully and be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-02-13/f26-blocker-review.2017-02-13-18.01.txt

Comment 8 Vendula Poncova 2017-02-14 12:12:00 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/960

Comment 9 Fedora End Of Life 2017-02-28 10:19:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.

Comment 10 Adam Williamson 2017-04-04 19:52:12 UTC
Any timeframe for 26.22 to actually happen?

Comment 11 Martin Kolman 2017-04-06 18:55:18 UTC
Should be already fixed - in the end there was no 26.22 as we branched in 26.21 - so 26.21.1 should have the fix.

Comment 12 Adam Williamson 2017-04-06 20:22:48 UTC
Indeed it doesn't look like this particular failure has occurred since the start of March (the test has occasionally failed, but none of the failures look like this - they're just openQA blips, timeouts or typing errors).

Comment 13 Adam Williamson 2017-04-07 00:45:56 UTC
So this was actually fixed in Alpha, no need for common bugs.