Bug 1377620

Summary: my usb stick is unrecognized after using mediawriter 's "restore" option
Product: [Fedora] Fedora Reporter: lnie <lnie>
Component: mediawriterAssignee: Martin Bříza <mbriza>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: kparal, mbriza
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: mediawriter-3.97.1-0.fc25 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-27 00:31:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
journal none

Description lnie 2016-09-20 08:43:13 UTC
Created attachment 1202776 [details]
journal

Description of problem:


Version-Release number of selected component (if applicable):
mediawriter-3.96.0-0.fc25.x86_64

How reproducible:


Steps to Reproduce:
1.insert the usb stick which have a live image written by mediawriter on it
2.click "Restore" button 
3.find the usb is unrecognized any more.By unrecognized I mean,even lsblk won't show anything about the usb

Actual results:


Expected results:


Additional info:

Comment 1 Martin Bříza 2016-09-20 09:33:14 UTC
What about after reinserting, does lsblk see it? It may be worth testing this outside of a virtual machine due to the changes to its layout.

Comment 2 lnie 2016-09-20 09:48:07 UTC
After reinserting,lsblk see it,but the Nautilus doesn't.
Mediawriter can see the usb,but the usb's reaction to "Create live usb" is different,please see #bz1377604 for more information.
And I got the following errors when I try to mount it to see what's in it.
[lnie@localhost ~]$ sudo mount /dev/sdc1 /mnt
mount: /dev/sdc1 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

Comment 3 Martin Bříza 2016-09-20 09:49:33 UTC
Does it have only one or more partitions? It should have three.

Comment 4 lnie 2016-09-20 09:59:47 UTC
Just one:
sdb                             8:16   1  29.5G  0 disk 
└─sdb1                          8:17   1  29.5G  0 part

Comment 5 Kamil Páral 2016-09-20 13:05:34 UTC
Please note that there are currently some issues in selinux that probably cause Nautilus to not show usb devices. Use e.g. gnome-disks to inspect drive contents.

Comment 6 lnie 2016-09-21 05:52:40 UTC
After format the usb using gnome-disks,Nautilus can see the usb device now.

Comment 7 Martin Bříza 2016-09-21 07:27:04 UTC
This is most likely caused by the current selinux policies, I was trying to debug a similar issue yesterday and it was fixed by switching to permissive selinux (setenforce 0).

Comment 8 Martin Bříza 2016-09-21 12:16:09 UTC
I can't fix the writing but the problem with detecting the drive afterwards should be fixed upstream now

Comment 9 Fedora Update System 2016-09-23 05:23:57 UTC
mediawriter-3.97.0-0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d84f684d42

Comment 10 Fedora Update System 2016-09-24 17:51:46 UTC
mediawriter-3.97.1-0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e34fd77aaf

Comment 11 Fedora Update System 2016-09-27 00:31:16 UTC
mediawriter-3.97.1-0.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.