Bug 1377604 - mediawriter do nothing before show "finished",if a different version is selected
Summary: mediawriter do nothing before show "finished",if a different version is selected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawriter
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1310542
TreeView+ depends on / blocked
 
Reported: 2016-09-20 08:17 UTC by lnie
Modified: 2016-09-27 00:30 UTC (History)
4 users (show)

Fixed In Version: mediawriter-3.97.1-0.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 00:30:57 UTC
Type: Bug


Attachments (Terms of Use)
video (787.80 KB, application/ogg)
2016-09-20 08:18 UTC, lnie
no flags Details
journal (422.27 KB, text/plain)
2016-09-20 08:18 UTC, lnie
no flags Details
video2 (1.14 MB, application/ogg)
2016-09-20 09:35 UTC, lnie
no flags Details
screenshot (533.27 KB, image/png)
2016-09-21 06:16 UTC, lnie
no flags Details
screenshot2 (424.88 KB, image/png)
2016-09-21 06:16 UTC, lnie
no flags Details

Description lnie 2016-09-20 08:17:03 UTC
Description of problem:
I have created a f24 live image on my usb stick using mediawriter,and then I try to create a f25 live image on that usb,but failed.
please see the attached video for more information.

Version-Release number of selected component (if applicable):
mediawriter-3.96.0-0.fc25.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2016-09-20 08:18:10 UTC
Created attachment 1202769 [details]
video

Comment 2 lnie 2016-09-20 08:18:58 UTC
Created attachment 1202770 [details]
journal

Comment 3 lnie 2016-09-20 09:35:19 UTC
Created attachment 1202801 [details]
video2

Comment 4 Adam DiFrischia 2016-09-20 15:41:16 UTC
As part of testday, I believe I ran into this bug as well, trying to write "Fedora-Workstation-Live-x86_64-24-1.2.iso", selected under "Other OS", it just says "Finished" without doing anything.

Host: Dell Latitude 3570

Comment 5 Giulio 'juliuxpigface' 2016-09-20 18:05:42 UTC
I've tried to write "Fedora-LXDE-Live-x86_64-25-20160912.n.0.iso" using "mediawriter-3.96.0-0.fc24.x86_64", but I hit this bug exactly as described on comment #4.

Comment 6 dominique 2016-09-20 18:12:00 UTC
Same problem as described on comment #4 with Fedora-KDE-Live-x86_64-25_Alpha-2.iso

In console I have that : 

[dominique@host-192-168-1-2 ~]$ mediawriter
Warning: Invalid URL: QUrl("") ((null):0, (null))
Warning: qrc:/components/DownloadDialog.qml:232: ReferenceError: liveUSBData is not defined (qrc:/components/DownloadDialog.qml:232, (null))
[dominique@host-192-168-1-2 ~]$

Comment 7 lnie 2016-09-21 06:15:36 UTC
The problem seems to be "custom os" doesn't work well,but not different-version's fault. You will also see this bug when you try to use the "custom os" with the same version(f24).And,when you try to use "custom os" with a clean usb stick,you will also see this bug.The difference between the two situations is shown in the attached screenshots:You won't see a message pops up after the "finish",if you use a clean usb stick.

Comment 8 lnie 2016-09-21 06:16:18 UTC
Created attachment 1203109 [details]
screenshot

Comment 9 lnie 2016-09-21 06:16:47 UTC
Created attachment 1203110 [details]
screenshot2

Comment 10 Martin Bříza 2016-09-21 08:13:53 UTC
Fixed upstream

Comment 11 Fedora Update System 2016-09-23 05:23:51 UTC
mediawriter-3.97.0-0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d84f684d42

Comment 12 dominique 2016-09-24 12:38:13 UTC
mediawriter-3.97.0-0.fc24 solve for me this issue.
Thank

Comment 13 Fedora Update System 2016-09-24 17:51:40 UTC
mediawriter-3.97.1-0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e34fd77aaf

Comment 14 Fedora Update System 2016-09-27 00:30:57 UTC
mediawriter-3.97.1-0.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.