Bug 1383603

Summary: Cannot upgrade to dnf-2.0: python3-dnf-plugins-extras-common-0.0.12-4.fc25.noarch requires python3-dnf < 2.0
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: dnf-plugins-extrasAssignee: rpm-software-management
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: jkadlcik, jsilhan, mluscon, rpm-software-management, vmukhame
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-30 10:58:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Petr Pisar 2016-10-11 08:15:18 UTC
Since Rawhide received dnf-2.0, I cannot upgrade the dnf because installed python3-dnf-plugins-extras-common-0.0.12-4.fc25.noarch requires python3-dnf < 2.0:

# LC_ALL=en_US.UTF-8 dnf --allowerasing upgrade
Last metadata expiration check: 0:08:27 ago on Tue Oct 11 10:06:34 2016.
Dependencies resolved.
 Package                    Arch     Version                    Repository 
Skipping packages with broken dependencies:
 dnf                        noarch   2.0.0-0.rc1.4.fc26         rawhide   222 k
 dnf-conf                   noarch   2.0.0-0.rc1.4.fc26         rawhide    41 k
 dnf-plugins-core           noarch   1.0.0-0.rc1.1.fc26         rawhide    38 k
 dnf-yum                    noarch   2.0.0-0.rc1.4.fc26         rawhide    23 k
 python3-dnf                noarch   2.0.0-0.rc1.4.fc26         rawhide   402 k
 python3-dnf-plugins-core   noarch   1.0.0-0.rc1.1.fc26         rawhide    76 k
 python3-hawkey             x86_64   0.7.0-0.1git179c0a6.fc26   rawhide    48 k

Transaction Summary
Skip  7 Packages

Nothing to do.
root@fedora-26:~ # LC_ALL=en_US.UTF-8 dnf --allowerasing upgrade --best
Last metadata expiration check: 0:08:31 ago on Tue Oct 11 10:06:34 2016.
Error: package python3-dnf-plugins-extras-common-0.0.12-4.fc25.noarch requires python3-dnf < 2.0, but none of the providers can be installed

Comment 1 Igor Gnatenko 2016-10-11 08:58:42 UTC
dnf-plugins-extras are not ready for dnf2.0 -- https://github.com/rpm-software-management/dnf-plugins-extras/pull/66

With that PR it will work perfectly, but it's not completely ready.

Comment 2 Igor Gnatenko 2016-10-24 11:11:01 UTC
We should release new dnf-plugins-extras this week.