Bug 1383603 - Cannot upgrade to dnf-2.0: python3-dnf-plugins-extras-common-0.0.12-4.fc25.noarch requires python3-dnf < 2.0
Summary: Cannot upgrade to dnf-2.0: python3-dnf-plugins-extras-common-0.0.12-4.fc25.no...
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2016-10-11 08:15 UTC by Petr Pisar
Modified: 2016-11-30 10:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2016-11-30 10:58:34 UTC
Type: Bug

Attachments (Terms of Use)

Description Petr Pisar 2016-10-11 08:15:18 UTC
Since Rawhide received dnf-2.0, I cannot upgrade the dnf because installed python3-dnf-plugins-extras-common-0.0.12-4.fc25.noarch requires python3-dnf < 2.0:

# LC_ALL=en_US.UTF-8 dnf --allowerasing upgrade
Last metadata expiration check: 0:08:27 ago on Tue Oct 11 10:06:34 2016.
Dependencies resolved.
 Package                    Arch     Version                    Repository 
Skipping packages with broken dependencies:
 dnf                        noarch   2.0.0-0.rc1.4.fc26         rawhide   222 k
 dnf-conf                   noarch   2.0.0-0.rc1.4.fc26         rawhide    41 k
 dnf-plugins-core           noarch   1.0.0-0.rc1.1.fc26         rawhide    38 k
 dnf-yum                    noarch   2.0.0-0.rc1.4.fc26         rawhide    23 k
 python3-dnf                noarch   2.0.0-0.rc1.4.fc26         rawhide   402 k
 python3-dnf-plugins-core   noarch   1.0.0-0.rc1.1.fc26         rawhide    76 k
 python3-hawkey             x86_64   0.7.0-0.1git179c0a6.fc26   rawhide    48 k

Transaction Summary
Skip  7 Packages

Nothing to do.
root@fedora-26:~ # LC_ALL=en_US.UTF-8 dnf --allowerasing upgrade --best
Last metadata expiration check: 0:08:31 ago on Tue Oct 11 10:06:34 2016.
Error: package python3-dnf-plugins-extras-common-0.0.12-4.fc25.noarch requires python3-dnf < 2.0, but none of the providers can be installed

Comment 1 Igor Gnatenko 2016-10-11 08:58:42 UTC
dnf-plugins-extras are not ready for dnf2.0 -- https://github.com/rpm-software-management/dnf-plugins-extras/pull/66

With that PR it will work perfectly, but it's not completely ready.

Comment 2 Igor Gnatenko 2016-10-24 11:11:01 UTC
We should release new dnf-plugins-extras this week.

Note You need to log in before you can comment on or make changes to this bug.