Bug 1389886

Summary: [abrt] xorg-x11-server-Xorg: RegionUninit(): Xorg killed by SIGABRT
Product: [Fedora] Fedora Reporter: Łukasz Faber <faber>
Component: xorg-x11-serverAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: faber, hdegoede, khiemu, ofourdan, rickyb.com, robert.wilhelm, sylvain, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/65a7b228f24f045f2b804398444ce1e82bd067ae
Whiteboard: abrt_hash:45901b2b1aeedc1ec44d56ce7cd482cdc3c1305c;VARIANT_ID=workstation;
Fixed In Version: xorg-x11-server-1.19.0-2.fc25 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-16 21:01:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace
none
File: cgroup
none
File: core_backtrace
none
File: dso_list
none
File: environ
none
File: limits
none
File: maps
none
File: mountinfo
none
File: namespaces
none
File: open_fds
none
File: proc_pid_status
none
File: var_log_messages
none
sample java inputdialog none

Description Łukasz Faber 2016-10-29 10:15:56 UTC
Description of problem:


Version-Release number of selected component:
xorg-x11-server-Xorg-1.19.0-0.3.20161026.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/Xorg vt3 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
crash_function: RegionUninit
executable:     /usr/libexec/Xorg
global_pid:     15765
kernel:         4.8.4-301.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (8 frames)
 #6 RegionUninit at ../../include/regionstr.h:166
 #7 RegionEmpty at ../../include/regionstr.h:194
 #8 damageRegionProcessPending at damage.c:298
 #9 damageComposite at damage.c:507
 #10 ProcRenderComposite at render.c:695
 #11 Dispatch at dispatch.c:469
 #12 dix_main at main.c:287
 #14 _start

Comment 1 Łukasz Faber 2016-10-29 10:16:02 UTC
Created attachment 1215214 [details]
File: backtrace

Comment 2 Łukasz Faber 2016-10-29 10:16:03 UTC
Created attachment 1215215 [details]
File: cgroup

Comment 3 Łukasz Faber 2016-10-29 10:16:04 UTC
Created attachment 1215216 [details]
File: core_backtrace

Comment 4 Łukasz Faber 2016-10-29 10:16:06 UTC
Created attachment 1215217 [details]
File: dso_list

Comment 5 Łukasz Faber 2016-10-29 10:16:07 UTC
Created attachment 1215218 [details]
File: environ

Comment 6 Łukasz Faber 2016-10-29 10:16:09 UTC
Created attachment 1215219 [details]
File: limits

Comment 7 Łukasz Faber 2016-10-29 10:16:11 UTC
Created attachment 1215220 [details]
File: maps

Comment 8 Łukasz Faber 2016-10-29 10:16:12 UTC
Created attachment 1215221 [details]
File: mountinfo

Comment 9 Łukasz Faber 2016-10-29 10:16:14 UTC
Created attachment 1215222 [details]
File: namespaces

Comment 10 Łukasz Faber 2016-10-29 10:16:15 UTC
Created attachment 1215223 [details]
File: open_fds

Comment 11 Łukasz Faber 2016-10-29 10:16:17 UTC
Created attachment 1215224 [details]
File: proc_pid_status

Comment 12 Łukasz Faber 2016-10-29 10:16:18 UTC
Created attachment 1215225 [details]
File: var_log_messages

Comment 13 Łukasz Faber 2016-11-08 16:25:02 UTC
I had this again today with xorg-x11-server-Xorg-1.19.0-0.7.rc2.fc25 and in parallel with https://bugzilla.redhat.com/show_bug.cgi?id=1384508

Comment 14 Robert Wilhelm 2016-12-07 20:06:26 UTC
Similar problem has been detected:

My Xserver crashes reliable after running small Java sample which should display Input box:

import javax.swing.JFrame;
import javax.swing.JOptionPane;
[..]
        JFrame frame = new JFrame();
        String s = JOptionPane.showInputDialog(frame, text);

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
crash_function: RegionUninit
executable:     /usr/libexec/Xorg
global_pid:     2030
kernel:         4.8.11-300.fc25.x86_64
package:        xorg-x11-server-Xorg-1.19.0-1.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         Xorg killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 15 Olivier Fourdan 2016-12-08 07:39:01 UTC
Well, chances are this is the same issue, would you mind attaching your reproducer either in this bug or in bug 1402599 ?

Comment 16 Adam Jackson 2016-12-12 18:40:22 UTC
Pretty sure I know what this is. Can you try this scratch X server build?

https://koji.fedoraproject.org/koji/taskinfo?taskID=16856474

Comment 17 rickyb.com 2016-12-13 00:28:05 UTC
(In reply to Adam Jackson from comment #16)
> Pretty sure I know what this is. Can you try this scratch X server build?
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=16856474

hi adam. yes, this addresses the issue I was having with a java app crashing Xorg.  thanks so much!

Comment 18 Łukasz Faber 2016-12-14 00:11:00 UTC
Thanks, seems that it has probably fixed the problem (it was a little unpredictable in my case).

I see some non-fatal hangups with DOSBox since installing, but I am not sure if this is related.

Comment 19 Hans de Goede 2016-12-15 12:04:45 UTC
(In reply to rickyb.com from comment #17)
> (In reply to Adam Jackson from comment #16)
> > Pretty sure I know what this is. Can you try this scratch X server build?
> > 
> > https://koji.fedoraproject.org/koji/taskinfo?taskID=16856474
> 
> hi adam. yes, this addresses the issue I was having with a java app crashing
> Xorg.  thanks so much!

Great, thanks for the feedback. I'm preparing a F25+ xserver update with some other fixes, I will also add in the fix for this.

Comment 20 Fedora Update System 2016-12-15 13:18:39 UTC
xorg-x11-server-1.19.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7f2899e78e

Comment 21 Robert Wilhelm 2016-12-15 17:29:21 UTC
Created attachment 1232287 [details]
sample java inputdialog

Here is sample Java file to reproduce this bug.
Run by 
$ javac Crash.java
$ java Crash

I use java-1.8.0-openjdk-1.8.0.111-4.b16.fc25.x86_64

Comment 22 Fedora Update System 2016-12-16 05:32:53 UTC
xorg-x11-server-1.19.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7f2899e78e

Comment 23 Robert Wilhelm 2016-12-16 06:52:33 UTC
After installing xorg-x11-server-Xorg-1.19.0-2.fc25.x86_64.rpm and  xorg-x11-server-common-1.19.0-2.fc25.x86_64.rpm from koji, my sample works fine.

Thank you for addressing this issue so quickly!

Comment 24 Fedora Update System 2016-12-16 21:01:28 UTC
xorg-x11-server-1.19.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Robert Wilhelm 2016-12-18 12:27:07 UTC
*** Bug 1402599 has been marked as a duplicate of this bug. ***