Bug 1402599 - [abrt] xorg-x11-server-Xorg: alloc_data(): Xorg killed by SIGABRT
Summary: [abrt] xorg-x11-server-Xorg: alloc_data(): Xorg killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1389886
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:b6c04eff1147ae4eae6303d47a1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-07 23:03 UTC by Robert Wilhelm
Modified: 2016-12-18 12:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-18 12:27:07 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (29.33 KB, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: cgroup (242 bytes, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: core_backtrace (3.91 KB, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: dso_list (6.66 KB, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: environ (620 bytes, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: limits (1.29 KB, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: maps (34.11 KB, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: mountinfo (3.70 KB, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: namespaces (102 bytes, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: open_fds (3.68 KB, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: proc_pid_status (1.11 KB, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details
File: var_log_messages (289 bytes, text/plain)
2016-12-07 23:03 UTC, Robert Wilhelm
no flags Details

Description Robert Wilhelm 2016-12-07 23:03:09 UTC
Description of problem:
My Xserver crashes reliable after running small Java sample which should display Input box:

import javax.swing.JFrame;
import javax.swing.JOptionPane;
[..]
        JFrame frame = new JFrame();
        String s = JOptionPane.showInputDialog(frame, text);

Same program used as in bug 1389886, but now quite different backtrace.
Seems some memory corruption taking place.

Version-Release number of selected component:
xorg-x11-server-Xorg-1.19.0-1.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
crash_function: alloc_data
executable:     /usr/libexec/Xorg
global_pid:     6648
kernel:         4.8.11-300.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 alloc_data at pixman-region.c:213
 #7 pixman_rect_alloc at pixman-region.c:465
 #8 pixman_op at pixman-region.c:828
 #9 pixman_region_union at pixman-region.c:1440
 #10 RegionUnion at ../../include/regionstr.h:241
 #11 damageRegionProcessPending at damage.c:293
 #12 damageComposite at damage.c:507
 #13 ProcRenderComposite at render.c:695
 #14 Dispatch at dispatch.c:469
 #15 dix_main at main.c:287

Comment 1 Robert Wilhelm 2016-12-07 23:03:15 UTC
Created attachment 1229229 [details]
File: backtrace

Comment 2 Robert Wilhelm 2016-12-07 23:03:16 UTC
Created attachment 1229230 [details]
File: cgroup

Comment 3 Robert Wilhelm 2016-12-07 23:03:18 UTC
Created attachment 1229231 [details]
File: core_backtrace

Comment 4 Robert Wilhelm 2016-12-07 23:03:20 UTC
Created attachment 1229232 [details]
File: dso_list

Comment 5 Robert Wilhelm 2016-12-07 23:03:21 UTC
Created attachment 1229233 [details]
File: environ

Comment 6 Robert Wilhelm 2016-12-07 23:03:22 UTC
Created attachment 1229234 [details]
File: limits

Comment 7 Robert Wilhelm 2016-12-07 23:03:25 UTC
Created attachment 1229235 [details]
File: maps

Comment 8 Robert Wilhelm 2016-12-07 23:03:26 UTC
Created attachment 1229236 [details]
File: mountinfo

Comment 9 Robert Wilhelm 2016-12-07 23:03:28 UTC
Created attachment 1229237 [details]
File: namespaces

Comment 10 Robert Wilhelm 2016-12-07 23:03:29 UTC
Created attachment 1229238 [details]
File: open_fds

Comment 11 Robert Wilhelm 2016-12-07 23:03:31 UTC
Created attachment 1229239 [details]
File: proc_pid_status

Comment 12 Robert Wilhelm 2016-12-07 23:03:32 UTC
Created attachment 1229240 [details]
File: var_log_messages

Comment 14 Olivier Fourdan 2016-12-08 07:37:39 UTC
Hi, thanks for your report, could you please attach the simple sample code that you use to reproduce, that could save us some time.

Comment 15 Robert Wilhelm 2016-12-18 12:27:07 UTC

*** This bug has been marked as a duplicate of bug 1389886 ***


Note You need to log in before you can comment on or make changes to this bug.