Bug 1400570

Summary: Build OpenLDAP with OpenSSL instead of MozNSS
Product: [Fedora] Fedora Reporter: Matus Honek <mhonek>
Component: openldapAssignee: Matus Honek <mhonek>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: mhonek, mreynolds, nhosoi, nkinder, rmeggins
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openldap-2.4.45-7.f28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1400578 (view as bug list) Environment:
Last Closed: 2018-02-08 13:42:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1400578, 1413515    

Description Matus Honek 2016-12-01 14:03:40 UTC
Description of problem:
We would like OpenLDAP to be compiled with OpenSSL instead of MozNSS.

Proposed fix:
Compile with --with-tls=openssl instead of --with-tls=moznss.

Considerations to be taken:
- backward MozNSS compatibility - MozNSS-specific TLS options and NSS database compatibility
- thorough testing

Additional info:
https://fedoraproject.org/wiki/Changes/OpenLDAPwithOpenSSL

Comment 1 Rich Megginson 2016-12-01 14:15:21 UTC
Need to coordinate this with the 389 team.

Comment 2 Fedora End Of Life 2017-02-28 10:42:26 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.

Comment 3 Jan Kurik 2017-08-15 06:38:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 6 Matus Honek 2018-02-08 13:42:23 UTC
This change is now part of the current Rawhide which is the future F28. Therefore, closing as NEXTRELEASE.