Bug 1406599

Summary: [RFE] Provide a GA version of ceph-iscsi-tools for iSCSI performance monitoring
Product: Red Hat Ceph Storage Reporter: Paul Cuzner <pcuzner>
Component: BuildAssignee: Jason Dillaman <jdillama>
Status: CLOSED ERRATA QA Contact: ceph-qe-bugs <ceph-qe-bugs>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 2.1CC: ceph-qe-bugs, hnallurv, icolle, jdillama, kdreyer, mkarnik, nthomas, rkanade, sankarshan
Target Milestone: rcKeywords: FutureFeature
Target Release: 2.3   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: ceph-iscsi-tools-2.0-2.el7cp Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-06-19 13:28:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1406551    

Description Paul Cuzner 2016-12-21 00:56:39 UTC
Description of problem:
ceph-iscsi-tools was included in RHCS 2.1 as a tech preview. This BZ requires that the gwtop tool within this package is moved to GA in support of the RHCS 2.2 release.

Version-Release number of selected component (if applicable):
Current upstream testing release is 2.0
Curent downstream is 1.1.5

Upstream repo : https://github.com/pcuzner/ceph-iscsi-tools/tree/lio-enhancements

Additional info:
gwtop uses performance co-pilot data collectors (pmda's) to gather performance metrics and display them to the admin. With RHCS 2.1, these metrics come from the device mapper metrics included with pcp. For RHCS 2.2 however, these metrics need to come from the LIO instance itself using the pcp-pmda-lio package

Refer to BZ 1406597 for the packaging request for the lio pmda

Comment 10 errata-xmlrpc 2017-06-19 13:28:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497