Bug 1406597 - [RFE] Include LIO domain agent for Performance co-Pilot
Summary: [RFE] Include LIO domain agent for Performance co-Pilot
Keywords:
Status: CLOSED DUPLICATE of bug 1410142
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: Performance-monitoring
Version: 2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3
Assignee: Ken Dreyer (Red Hat)
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-21 00:48 UTC by Paul Cuzner
Modified: 2017-01-04 15:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-04 15:12:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Paul Cuzner 2016-12-21 00:48:43 UTC
Description of problem:
A PMDA has been written for LIO (ceph/iscsi) performance stats which allows other tools to report on rbd's exported over iscsi. This RFE requires that the pmda is packaged and available to RHCS 2.2

Version-Release number of selected component (if applicable):


Upstream Project
https://github.com/pcuzner/pcp-pmda-lio

Additional info:
The statistics extracted by the pmda are held in the kernel's configfs filesystem, so in systems with SELINUX enabled an updated SELINUX policu is needed to allow pmcd access to configfs. An example TE file is provided in the repo

Comment 2 Jason Dillaman 2017-01-04 15:12:54 UTC

*** This bug has been marked as a duplicate of bug 1410142 ***


Note You need to log in before you can comment on or make changes to this bug.