Bug 1410606

Summary: Imported VMs has max memory 0
Product: [oVirt] ovirt-engine Reporter: jniederm
Component: BLL.VirtAssignee: jniederm
Status: CLOSED CURRENTRELEASE QA Contact: meital avital <mavital>
Severity: high Docs Contact:
Priority: high    
Version: futureCC: bugs, mgoldboi, tjelinek, tnisan
Target Milestone: ovirt-4.1.1Keywords: Regression
Target Release: 4.1.1Flags: rule-engine: ovirt-4.1+
rule-engine: blocker+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-04-21 09:39:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jniederm 2017-01-05 21:11:56 UTC
Description of problem:
VMs imported form export domain that were created in 4.0 engine have after import maximum memory = 0MB.

Version-Release number of selected component (if applicable):
4.2 master, commit 460248a

How reproducible:
100%

Steps to Reproduce:
1. Create a VM in 4.0 engine and export it to an export domain
2. Import the VM in 4.1 engine
3. Edit the imported VM > side tab 'System' > 'Maximum memory' field

Actual results:
... is 0MB

Expected results:
a predictable value in valid range, i.e. [memory size; option *MaxMemorySizeInMB]

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2017-01-25 12:21:10 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 meital avital 2017-02-15 11:21:59 UTC
Verified on version: 4.1.1-0.1.el7