Bug 1410606 - Imported VMs has max memory 0
Summary: Imported VMs has max memory 0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: future
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.1.1
: 4.1.1
Assignee: jniederm
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 21:11 UTC by jniederm
Modified: 2017-04-21 09:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:39:58 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
rule-engine: blocker+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 69741 0 master MERGED core: Max memory validation in import commands 2017-01-22 16:52:25 UTC
oVirt gerrit 69742 0 master MERGED core: Handling of missing maxMemory unified 2017-01-22 14:19:01 UTC
oVirt gerrit 69771 0 ovirt-engine-4.1 MERGED core: Max memory validation in import commands 2017-01-26 13:22:54 UTC
oVirt gerrit 69772 0 ovirt-engine-4.1 MERGED core: Handling of missing maxMemory unified 2017-01-26 13:21:37 UTC

Description jniederm 2017-01-05 21:11:56 UTC
Description of problem:
VMs imported form export domain that were created in 4.0 engine have after import maximum memory = 0MB.

Version-Release number of selected component (if applicable):
4.2 master, commit 460248a

How reproducible:
100%

Steps to Reproduce:
1. Create a VM in 4.0 engine and export it to an export domain
2. Import the VM in 4.1 engine
3. Edit the imported VM > side tab 'System' > 'Maximum memory' field

Actual results:
... is 0MB

Expected results:
a predictable value in valid range, i.e. [memory size; option *MaxMemorySizeInMB]

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2017-01-25 12:21:10 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 meital avital 2017-02-15 11:21:59 UTC
Verified on version: 4.1.1-0.1.el7


Note You need to log in before you can comment on or make changes to this bug.