Bug 1411170

Summary: Network Router provisioning must call and use raw create method
Product: Red Hat CloudForms Management Engine Reporter: Gilles Dubreuil <gdubreui>
Component: ProvidersAssignee: Gilles Dubreuil <gdubreui>
Status: CLOSED CURRENTRELEASE QA Contact: Omri Hochman <ohochman>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5.8.0CC: cpelland, gblomqui, gdubreui, jfrey, jhardy, obarenbo, tzumainn
Target Milestone: GAKeywords: Reopened, TestOnly, ZStream
Target Release: 5.8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 5.8.0.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1413677 (view as bug list) Environment:
Last Closed: 2017-06-12 16:35:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Openstack Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1413677    

Description Gilles Dubreuil 2017-01-08 23:55:56 UTC
In https://github.com/ManageIQ/manageiq/pull/12045 the call to  'create_network_router' replaces 'raw_create_network_router' but the method name itself wasn't  replaced. This wasn't meant for this PR. So when PR#12045 is backported to euwe then https://github.com/ManageIQ/manageiq/pull/13072 Pull Request which takes care of the method renaming must be backported too.

Comment 3 Gilles Dubreuil 2017-01-10 03:41:07 UTC
https://github.com/ManageIQ/manageiq/pull/13072 has been merged on master branch.
Since this issue doesn't apply to euwe (5.7.1) we can close it.

Comment 4 Tzu-Mainn Chen 2017-01-16 14:36:12 UTC
Gilles, just to double-check - are you saying we don't need https://github.com/ManageIQ/manageiq/pull/13072 and https://github.com/ManageIQ/manageiq/pull/13462 in Euwe after all?

Comment 5 Tzu-Mainn Chen 2017-01-16 16:12:46 UTC
After further checking, this is needed for https://bugzilla.redhat.com/show_bug.cgi?id=1394284; moving to POST

Comment 7 Gilles Dubreuil 2017-02-14 04:46:10 UTC
Sorry for late reply, that one slipped out of sight.

To me it seems one of the backport overlapped, anyway it doesn't matter as now all the raw calls are wrapped.

Thanks

Comment 8 Ronnie Rasouli 2017-03-08 13:12:00 UTC
verified on 5.8.0.3
created and delete router