Bug 141119
| Summary: | sshd failed to bind to 0.0.0.0 port 22 | ||
|---|---|---|---|
| Product: | [Fedora] Fedora | Reporter: | feily |
| Component: | openssh | Assignee: | Tomas Mraz <tmraz> |
| Status: | CLOSED DUPLICATE | QA Contact: | |
| Severity: | low | Docs Contact: | |
| Priority: | medium | ||
| Version: | 3 | CC: | bugs.michael, djuran |
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | All | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2005-02-10 10:23:31 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Confirmed, but only if IPv6 kernel module is loaded (which is the default). On "service sshd restart" I see the following in /var/log/secure: Jan 3 06:20:09 gw sshd[29213]: Server listening on :: port 22. Jan 3 06:20:09 gw sshd[29213]: error: Bind to port 22 on 0.0.0.0 failed: Address already in use. This duplicates bug #122148 and bug #120302. |
From Bugzilla Helper: User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0 Description of problem: everytime openssh starts up I get the following error in my logwatch: --------------------- SSHD Begin ------------------------ Failed to bind: 0.0.0.0 port 22 (Address already in use) : 1 Time(s) ---------------------- SSHD End ------------------------- but sshd seems to work as expected. Cannot find any problem Version-Release number of selected component (if applicable): openssh-3.9p1-7 How reproducible: Always Steps to Reproduce: 1. start sshd with default settings Expected Results: this error should not be there Additional info: I've an eth0, an eth1 and an ppp0 interface set up