Bug 122148 - Bind to port 22 on 0.0.0.0 failed (IPv6 v IPv4 confusion)
Bind to port 22 on 0.0.0.0 failed (IPv6 v IPv4 confusion)
Status: CLOSED DUPLICATE of bug 120302
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 17:59 EDT by Florin Andrei
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 11:22:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2004-04-30 17:59:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
While the system boots up, you can see this thing in /var/log/secure:

Apr 30 15:01:49 disposable sshd[1315]: Server listening on :: port 22.
Apr 30 15:01:49 disposable sshd[1315]: error: Bind to port 22 on
0.0.0.0 failed: Address already in use.

But sshd seems to work fine otherwise.

Version-Release number of selected component (if applicable):
openssh-3.6.1p2-34

How reproducible:
Always

Steps to Reproduce:
1.boot up
2.
3.
    

Actual Results:  see above

Expected Results:  there should be no error

Additional info:

See bug #122043 for details about the system.
Comment 1 Adam Bowns 2004-05-29 11:58:42 EDT
This also happened to me on a clean install of FC2. ssh works fine,
but I keep getting the error mentioned above.
Comment 2 Adam Bowns 2004-05-29 18:50:44 EDT
I think I have found the reason behind this error. sshd binds IPv6
first, then when it tries to bind IPv4 it finds that the address is
already in use (hence the error). The reason it still continues to
function properly is because the IPv4 traffic is able to use the IPv6
socket that sshd is listneing on.

Could someone please re-lable this bug to FC version 2, and also add
some more keywords.
Comment 3 Florin Andrei 2004-06-17 15:12:42 EDT
I added this line to /etc/modprobe.conf

install ipv6 /bin/true

Then rebooted the system. The ssh bug went away.

Now, i thought NETWORKING_IPV6=no in /etc/sysconfig/network was enough
to turn off IPv6. It's not enough on my system, i have to fiddle with
modprobe.conf.
Maybe i should fill in a different bug report on this issue? :-)
Comment 4 Damien Miller 2004-08-24 20:55:58 EDT
This is a dupe of bug #120302
Comment 5 Tomas Mraz 2005-02-07 11:22:13 EST

*** This bug has been marked as a duplicate of 120302 ***

Note You need to log in before you can comment on or make changes to this bug.