Bug 1413654

Summary: many vm create/remove/stop/start Azure events are absent in timelines though present in DB
Product: Red Hat CloudForms Management Engine Reporter: Satoe Imaishi <simaishi>
Component: ProvidersAssignee: Bronagh Sorota <bsorota>
Status: CLOSED ERRATA QA Contact: Ievgen Zapolskyi <izapolsk>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.6.0CC: cpelland, dajohnso, gblomqui, jfrey, jhardy, obarenbo, simaishi
Target Milestone: GAKeywords: ZStream
Target Release: 5.6.4   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: provider:event:azure:timeline
Fixed In Version: 5.6.4.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1390587 Environment:
Last Closed: 2017-03-09 17:07:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Azure Target Upstream Version:
Bug Depends On: 1390587    
Bug Blocks:    

Comment 2 CFME Bot 2017-01-16 18:36:13 UTC
New commit detected on ManageIQ/manageiq/darga:
https://github.com/ManageIQ/manageiq/commit/7afa8faee5d96340b073a210cd96179bc8e5b0d0

commit 7afa8faee5d96340b073a210cd96179bc8e5b0d0
Author:     Greg Blomquist <blomquisg@gmail.com>
AuthorDate: Fri Nov 18 12:09:40 2016 -0500
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Mon Jan 16 13:31:24 2017 -0500

    Merge pull request #10 from bronaghs/event_not_mapped_to_vm_bz1390587
    
    Update the case of the Azure event vm_ems_ref property
    (cherry picked from commit f616de944c13e2b50e3146597cd57b58c2579b9d)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1413654

 app/models/manageiq/providers/azure/event_catcher_mixin.rb            | 4 ++--
 .../providers/azure/cloud_manager/event_catcher/runner_spec.rb        | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comment 4 errata-xmlrpc 2017-03-09 17:07:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0474.html