Bug 1390587 - many vm create/remove/stop/start Azure events are absent in timelines though present in DB [NEEDINFO]
Summary: many vm create/remove/stop/start Azure events are absent in timelines though ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.8.0
Assignee: Bronagh Sorota
QA Contact: Ievgen Zapolskyi
URL:
Whiteboard: provider:event:azure:timeline
Depends On:
Blocks: 1397509 1413654
TreeView+ depends on / blocked
 
Reported: 2016-11-01 13:21 UTC by Ievgen Zapolskyi
Modified: 2017-06-12 17:18 UTC (History)
7 users (show)

Fixed In Version: 5.8.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1397509 1413654 (view as bug list)
Environment:
Last Closed: 2017-06-12 17:18:56 UTC
Category: Bug
Cloudforms Team: Azure
Target Upstream Version:
simaishi: needinfo? (gblomqui)


Attachments (Terms of Use)
event_streams cut (737.25 KB, text/plain)
2016-11-01 13:21 UTC, Ievgen Zapolskyi
no flags Details

Description Ievgen Zapolskyi 2016-11-01 13:21:44 UTC
Created attachment 1216113 [details]
event_streams cut

Description of problem:
CFME receives raw (EmsEvent) events when autotests create/remove/start/stop vm in Azure.
However many such events are absent in timelines for provider/vm/azone etc.
It seems not all raw events are correctly updated in DB and that's a reason for ignoring them during rendering timelines.


Version-Release number of selected component (if applicable):
5.6.2.2

How reproducible:
100%

Steps to Reproduce:
1. Add Azure provider to CFME
2. Create/Start/Stop/Remove vm in Azure 
3. Check event_streams table for events related to just created vm
4. Open Timelines view for Azure provider

Actual results:
Timelines for Azure doesn't contain events related to just created/removed vm.
The event_streams table contains raw (EmsEvent) events for every operation.
The event_streams fields like vm_name, etc are empty.

Expected results:
Timelines for Azure should show all supported events.


Additional info:
event_streams table is attached.
name of vm used for testing is "test_tt_LivSa0DQpP".

Comment 4 CFME Bot 2016-11-18 17:12:51 UTC
New commit detected on ManageIQ/manageiq-providers-azure/master:
https://github.com/ManageIQ/manageiq-providers-azure/commit/84141b3446e799e9e4068b451797294b2a28c058

commit 84141b3446e799e9e4068b451797294b2a28c058
Author:     Bronagh Sorota <bsorota@redhat.com>
AuthorDate: Thu Nov 10 11:39:42 2016 -0500
Commit:     Bronagh Sorota <bsorota@redhat.com>
CommitDate: Tue Nov 15 14:43:34 2016 -0500

    Update the VM ems_ref in the Azure event to match the case
    of the ems_ref in the VM table. This will always ensure the event / VM
    association will happen.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1390587

 app/models/manageiq/providers/azure/event_catcher_mixin.rb            | 4 ++--
 .../providers/azure/cloud_manager/event_catcher/runner_spec.rb        | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comment 9 Ievgen Zapolskyi 2017-03-24 10:36:16 UTC
cannot verify because Timelines is completely broken since 5.8.0.4.

Comment 10 Ievgen Zapolskyi 2017-04-21 14:00:58 UTC
in 5.8.0.11


Note You need to log in before you can comment on or make changes to this bug.