Bug 1414166

Summary: [RFE] Support local storage domains in RHV datacenter clusters
Product: Red Hat Enterprise Virtualization Manager Reporter: Ashton Davis <asdavis>
Component: RFEsAssignee: Scott Herold <sherold>
Status: CLOSED DUPLICATE QA Contact: Gil Klein <gklein>
Severity: high Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: asdavis, gklein, jcall, kmorey, lsurette, mawest, nstephan, rbalakri, srevivo, ykaul, ylavi
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-26 14:54:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Node RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ashton Davis 2017-01-17 23:27:30 UTC
Requested Feature:

Fully support local storage domains in hypervisor clusters.

Description of feature:

Currently, multiple clustered hypervisors can't each run their own local storage domain. The request is to allow that functionality, and all normal storage operation controls (except for the shared-only features, like migration). Treat local storage like we treat shared storage in a clustered environment. This means also allowing multiple local storage domains (say, one per host in a cluster), as well as shared storage across the cluster. 

Example use case:

For high-IO virtualized workloads, local storage is orders of magnitude cheaper than the equivalent performance out of shared storage, especially when the physical footprint is quite small. Here's an actual customer example (customer name removed):

$COMPANY does live video streaming. The [virtualized] workload requires high IO and low storage latency. They have clustered hypervisors running this workload, using SSDs installed locally to each hypervisor. This affords them high IOPS at a "low" cost. The application itself is designed to be highly available, so HA/migration at the virtualization level is not necessary.

This customer also has a small footprint colocated at 30+ sites where the streaming originates running a similar workload to SSD, running on two clustered hypervisors per site. It would be especially uneconomical to purchase high-IO shared storage for this use case, so local SSDs are the best fit.

Comment 6 Yaniv Lavi 2017-01-26 14:54:41 UTC

*** This bug has been marked as a duplicate of bug 1109597 ***