Bug 1109597 - [RFE][Tracker][Dalton] Allow shared and local storage in the same DataCenter
Summary: [RFE][Tracker][Dalton] Allow shared and local storage in the same DataCenter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.6
: ---
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
: 1414166 (view as bug list)
Depends On: 1134318
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-15 19:21 UTC by Itamar Heim
Modified: 2020-08-03 15:28 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: Technology Preview
Doc Text:
This release allows the creation of single-brick Gluster volumes to enable local storage to be used as a storage domain for shared data centers. As a result, both local storage and shared storage can be used. This feature is a Tech Preview.
Clone Of:
Environment:
Last Closed: 2018-09-04 13:41:42 UTC
oVirt Team: Gluster
Target Upstream Version:
sherold: Triaged+
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 141623 0 None None None Never
Red Hat Product Errata RHBA-2018:2623 0 None None None 2018-09-04 13:42:30 UTC

Description Itamar Heim 2014-06-15 19:21:54 UTC
Multiple Storage Domains are available in 3.4 via 1052318.
This RFE is to track mixing local and shared storage domains.
some details are in bug 757291

Comment 4 Sven Kieske 2014-09-25 14:47:08 UTC
BZ 757291 is marked as private, could you open it to the public?

Comment 5 Itamar Heim 2014-11-30 13:02:16 UTC
(In reply to Sven Kieske from comment #4)
> BZ 757291 is marked as private, could you open it to the public?

bug 757291 tracked the request for both allowing mixed shared types (available since 3.4) and local. this was split to track allowing local with shared, now that mixed shared is available.

Comment 6 Yaniv Lavi 2017-01-26 14:54:41 UTC
*** Bug 1414166 has been marked as a duplicate of this bug. ***

Comment 7 SATHEESARAN 2018-07-30 06:55:14 UTC
Tested this feature with ovirt-4.2.5

LocalDC could be created and single brick gluster volume could be used as gluster storage domain to store VM disks. VMs can be created out of it.

Comment 8 Yaniv Lavi 2018-07-30 07:31:40 UTC
(In reply to SATHEESARAN from comment #7)
> Tested this feature with ovirt-4.2.5
> 
> LocalDC could be created and single brick gluster volume could be used as
> gluster storage domain to store VM disks. VMs can be created out of it.

Why are you using localdc?
You should test on regular clusters. Mixing shared and local single brick and replica 3 volumes.

Comment 10 SATHEESARAN 2018-09-04 12:35:44 UTC
(In reply to Yaniv Lavi from comment #8)
> (In reply to SATHEESARAN from comment #7)
> > Tested this feature with ovirt-4.2.5
> > 
> > LocalDC could be created and single brick gluster volume could be used as
> > gluster storage domain to store VM disks. VMs can be created out of it.
> 
> Why are you using localdc?
> You should test on regular clusters. Mixing shared and local single brick
> and replica 3 volumes.

Yaniv, 

Yes this combination is also validated.
Used a regular shared DC with gluster storage domains with single brick distributed volume, replica 3 volume, arbitrated replicate volume

Comment 12 errata-xmlrpc 2018-09-04 13:41:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2623


Note You need to log in before you can comment on or make changes to this bug.