Bug 1417158 (CVE-2017-5610, CVE-2017-5611, CVE-2017-5612)

Summary: CVE-2017-5610 CVE-2017-5611 CVE-2017-5612 wordpress: Multiple security fixes in 4.7.2
Product: [Other] Security Response Reporter: Adam Mariš <amaris>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: fedora, gwync
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: wordpress 4.7.2 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-09 12:01:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1417159, 1417160    
Bug Blocks:    

Description Adam Mariš 2017-01-27 10:50:51 UTC
WordPress versions 4.7.1 and earlier are affected by three security issues:

1. The user interface for assigning taxonomy terms in Press This is shown to users who do not have permissions to use it.

2. WP_Query is vulnerable to a SQL injection (SQLi) when passing unsafe data. WordPress core is not directly vulnerable to this issue, but we’ve added hardening to prevent plugins and themes from accidentally causing a vulnerability.

3. A cross-site scripting (XSS) vulnerability was discovered in the posts list table.

External Reference:


Comment 1 Adam Mariš 2017-01-27 10:52:50 UTC
Created wordpress tracking bugs for this issue:

Affects: fedora-all [bug 1417159]
Affects: epel-all [bug 1417160]

Comment 2 Andrej Nemec 2017-01-30 09:29:11 UTC
CVE assignment: