Bug 1417158 (CVE-2017-5610, CVE-2017-5611, CVE-2017-5612) - CVE-2017-5610 CVE-2017-5611 CVE-2017-5612 wordpress: Multiple security fixes in 4.7.2
Summary: CVE-2017-5610 CVE-2017-5611 CVE-2017-5612 wordpress: Multiple security fixes ...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2017-5610, CVE-2017-5611, CVE-2017-5612
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1417159 1417160
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 10:50 UTC by Adam Mariš
Modified: 2019-09-29 14:05 UTC (History)
2 users (show)

Fixed In Version: wordpress 4.7.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-09 12:01:11 UTC


Attachments (Terms of Use)

Description Adam Mariš 2017-01-27 10:50:51 UTC
WordPress versions 4.7.1 and earlier are affected by three security issues:


1. The user interface for assigning taxonomy terms in Press This is shown to users who do not have permissions to use it.

2. WP_Query is vulnerable to a SQL injection (SQLi) when passing unsafe data. WordPress core is not directly vulnerable to this issue, but we’ve added hardening to prevent plugins and themes from accidentally causing a vulnerability.

3. A cross-site scripting (XSS) vulnerability was discovered in the posts list table.

External Reference:

https://wordpress.org/news/2017/01/wordpress-4-7-2-security-release/

Comment 1 Adam Mariš 2017-01-27 10:52:50 UTC
Created wordpress tracking bugs for this issue:

Affects: fedora-all [bug 1417159]
Affects: epel-all [bug 1417160]

Comment 2 Andrej Nemec 2017-01-30 09:29:11 UTC
CVE assignment:

http://seclists.org/oss-sec/2017/q1/217


Note You need to log in before you can comment on or make changes to this bug.