Bug 1419634

Summary: Focus not always on window on top of the z axis
Product: [Fedora] Fedora Reporter: Ed Greenberg <edg>
Component: marcoAssignee: Wolfgang Ulbrich <fedora>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: edg, fedora, rdieter, scx.mail, stefano
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: marco-1.16.1-1.fc24 marco-1.16.1-1.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-22 06:51:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ed Greenberg 2017-02-06 15:46:20 UTC
Description of problem:

Using 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)

Frequently, the keyboard and mouse focus is not set to the window on top of the z axis.  For instance, clicking a new program will open it underneath the currently selected application, and it has the focus. The top app can't even be used. 

Version-Release number of selected component (if applicable):


How reproducible:  No logic to it. One just has a window that is not taking input, because the window below is grabbing it. 

Additional info:

Seems to happen more with windows that appear by being moved from other workspaces, but sometimes happens with newly opened applications.

Comment 1 Tomasz Tomasik 2017-03-31 04:37:48 UTC
This is probably a duplicate of bug #1376540.
https://bugzilla.redhat.com/show_bug.cgi?id=1376540

The problem also occurs on computers with Nvidia GPU, and applies also to MATE 1.16 from EPEL7.
- mate-desktop.x86_64 - 1.16.1-3.el7 from @epel
- marco.x86_64 - 1.16.0-1.el7 from @epel
- kmod-nvidia.x86_64 - 375.39-2.el7.elrepo from @elrepo
- nvidia-x11-drv.x86_64 - 375.39-1.el7.elrepo from @elrepo

Comment 2 Wolfgang Ulbrich 2017-05-02 17:41:15 UTC
As this issue isn't easy to reproduce in need your help.
Please test those marco builds.
I reverted a commit and i can't duplicate the issue any more since 2 days.
For f26: 
https://koji.fedoraproject.org/koji/taskinfo?taskID=19369066
For f25:
https://koji.fedoraproject.org/koji/taskinfo?taskID=19369224
For f24:
https://koji.fedoraproject.org/koji/taskinfo?taskID=19369240
rhel7/cento7:
https://koji.fedoraproject.org/koji/taskinfo?taskID=19369256

Comment 3 Fedora Update System 2017-05-06 15:58:53 UTC
marco-1.16.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-4a48af810a

Comment 4 Fedora Update System 2017-05-06 15:59:01 UTC
marco-1.16.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-54e2fdc876

Comment 5 Tomasz Tomasik 2017-05-06 16:12:24 UTC
(In reply to Wolfgang Ulbrich from comment #2)
I was unable to reproduce this error within the last 4 days of normal work.

Comment 6 Fedora Update System 2017-05-07 00:26:50 UTC
marco-1.16.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-4a48af810a

Comment 7 Fedora Update System 2017-05-07 02:01:37 UTC
marco-1.16.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-54e2fdc876

Comment 8 Fedora Update System 2017-05-10 19:08:45 UTC
marco-1.16.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-4a48af810a

Comment 9 Fedora Update System 2017-05-10 19:12:30 UTC
marco-1.16.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-54e2fdc876

Comment 10 Fedora Update System 2017-05-12 19:55:34 UTC
marco-1.16.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-4a48af810a

Comment 11 Fedora Update System 2017-05-12 22:33:13 UTC
marco-1.16.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-54e2fdc876

Comment 12 Fedora Update System 2017-05-22 06:51:19 UTC
marco-1.16.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2017-05-29 07:26:03 UTC
marco-1.16.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.